mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
757aeb1d3a
* gnu/packages/patches/freeimage-libtiff-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (freeimage)[source](patches): Add it.
19 lines
1,003 B
Diff
19 lines
1,003 B
Diff
Use the new TIFFFieldSetGetSize API from libtiff 4.4 instead of the
|
|
private and removed _TIFFDataSize declared in the unbundling patch.
|
|
|
|
Patch taken from Fedora:
|
|
|
|
https://src.fedoraproject.org/rpms/freeimage/blob/rawhide/f/freeimage-libtiff44.patch
|
|
|
|
diff -rupN --no-dereference freeimage-svn-r1889-FreeImage-trunk/Source/Metadata/XTIFF.cpp freeimage-svn-r1889-FreeImage-trunk-new/Source/Metadata/XTIFF.cpp
|
|
--- freeimage-svn-r1889-FreeImage-trunk/Source/Metadata/XTIFF.cpp 2022-06-23 11:56:32.561043826 +0200
|
|
+++ freeimage-svn-r1889-FreeImage-trunk-new/Source/Metadata/XTIFF.cpp 2022-06-23 11:56:32.764043827 +0200
|
|
@@ -747,7 +747,7 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
|
|
continue;
|
|
}
|
|
// type of storage may differ (e.g. rationnal array vs float array type)
|
|
- if((unsigned)_TIFFDataSize(tif_tag_type) != FreeImage_TagDataWidth(tag_type)) {
|
|
+ if((unsigned)TIFFFieldSetGetSize(fld) != FreeImage_TagDataWidth(tag_type)) {
|
|
// skip tag or _TIFFmemcpy will fail
|
|
continue;
|
|
}
|