guix/gnu/packages/patches/pstoedit-fix-plainC.patch
Maxim Cournoyer 43395dd244
gnu: pstoedit: Update to 4.00.
* gnu/packages/graphics.scm (pstoedit): Update to 4.00.
[source]: Apply patches.
[arguments]: New field.
[inputs]: Remove labels.  Add glib and pango.
* gnu/packages/patches/pstoedit-fix-gcc12.patch: New file.
* gnu/packages/patches/pstoedit-fix-plainC.patch: Likewise.
* gnu/packages/patches/pstoedit-pkglibdir.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Register them.

Change-Id: Ia17dae0ebc3e08b573b02431b10cc689a72a07dd
2024-08-31 10:44:57 +02:00

47 lines
1.4 KiB
Diff

Retrieved from Fedora: https://src.fedoraproject.org/rpms/pstoedit/tree
diff --git a/src/pstoedit.cpp b/src/pstoedit.cpp
index a718f37..ac0df37 100755
--- a/src/pstoedit.cpp
+++ b/src/pstoedit.cpp
@@ -327,6 +327,11 @@ extern FILE *yyin; // used by lexer
// otherwise we could declare it locally where it is used
+extern "C" DLLEXPORT void loadpstoeditplugins_plainC(const char *progname, int verbose)
+{
+ return loadpstoeditplugins(progname, cerr, (bool) verbose);
+}
+
static void usage(ostream & outstream, bool forTeX, bool withdetails, bool withcategories )
{
if (withcategories) {
diff --git a/src/pstoedit.h b/src/pstoedit.h
index 294b3c2..74ebf2a 100755
--- a/src/pstoedit.h
+++ b/src/pstoedit.h
@@ -100,8 +100,13 @@ void clearPstoeditDriverInfo_plainC(struct DriverDescription_S * ptr);
#ifdef __cplusplus
extern "C" DLLEXPORT
-#endif
void loadpstoeditplugins(const char* progname, std::ostream & errstream, bool verbose);
+#endif
+
+#ifdef __cplusplus
+extern "C" DLLEXPORT
+#endif
+void loadpstoeditplugins_plainC(const char* progname, int verbose);
#ifdef __cplusplus
extern "C" DLLEXPORT
--- a/src/pstoedit.orig.h 2023-07-22 19:27:43.691166652 +0200
+++ b/src/pstoedit.h 2023-07-22 19:31:18.897952130 +0200
@@ -37,6 +37,7 @@
#endif
#include "pstoedll.h"
+#include <stdbool.h>
typedef int (*execute_interpreter_function)(int argc, const char * const argv[]);