mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
607e48ba3c
* gnu/packages/image-processing.scm: (vtk-7): New variable. * gnu/packages/patches/vtk-7-gcc-10-compat.patch: New patch. * gnu/packages/patches/vtk-7-hdf5-compat.patch: Likewise. * gnu/packages/patches/vtk-7-python-compat.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them.
14 lines
587 B
Diff
14 lines
587 B
Diff
Retrieved from
|
|
https://sources.debian.org/src/vtk7/7.1.1%2Bdfsg2-10.1/debian/patches/.
|
|
|
|
--- a/CMake/VTKGenerateExportHeader.cmake
|
|
+++ b/CMake/VTKGenerateExportHeader.cmake
|
|
@@ -174,7 +174,7 @@
|
|
execute_process(COMMAND ${CMAKE_C_COMPILER} --version
|
|
OUTPUT_VARIABLE _gcc_version_info
|
|
ERROR_VARIABLE _gcc_version_info)
|
|
- string(REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*"
|
|
+ string(REGEX MATCH "[0-9]*\\.[0-9]\\.[0-9]*"
|
|
_gcc_version "${_gcc_version_info}")
|
|
# gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
|
|
# patch level, handle this here:
|