mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
dc26246ef6
* gnu/packages/patches/python-pillow-use-zlib-1.3.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python-xyz.scm (python-pillow): Use it. Change-Id: I97e706c11f616c42fb604cb616a94663f389a376
21 lines
789 B
Diff
21 lines
789 B
Diff
From 9ef7cb39def45b0fe1cdf4828ca20838a1fc39d1 Mon Sep 17 00:00:00 2001
|
|
From: Andrew Murray <radarhere@users.noreply.github.com>
|
|
Date: Fri, 18 Aug 2023 22:22:51 +1000
|
|
Subject: [PATCH] Updated zlib to 1.3
|
|
|
|
---
|
|
Tests/test_file_png.py | 2 +-
|
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
|
|
diff --git a/Tests/test_file_png.py b/Tests/test_file_png.py
|
|
index 3ffe93c6d15..f8df88d6777 100644
|
|
--- a/Tests/test_file_png.py
|
|
+++ b/Tests/test_file_png.py
|
|
@@ -79,6 +79,6 @@ def get_chunks(self, filename):
|
|
|
|
def test_sanity(self, tmp_path):
|
|
# internal version number
|
|
- assert re.search(r"\d+\.\d+\.\d+(\.\d+)?$", features.version_codec("zlib"))
|
|
+ assert re.search(r"\d+(\.\d+){1,3}$", features.version_codec("zlib"))
|
|
|
|
test_file = str(tmp_path / "temp.png")
|