mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
891b045f38
Fixes <https://bugs.gnu.org/43088>. * gnu/packages/patches/mailutils-fix-uninitialized-variable.patch: New file. * gnu/packages/mail.scm (mailutils)[source]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch.
26 lines
688 B
Diff
26 lines
688 B
Diff
From 5ca6382fe8adb5bc436a6d873c8b86c69d5abfd1 Mon Sep 17 00:00:00 2001
|
|
From: Sergey Poznyakoff <gray@gnu.org>
|
|
Date: Sun, 13 Sep 2020 14:43:46 +0300
|
|
Subject: [PATCH] Fix uninitialized variable in readmsg
|
|
|
|
* readmsg/readmsg.c (main): Initialize weedc.
|
|
---
|
|
readmsg/readmsg.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/readmsg/readmsg.c b/readmsg/readmsg.c
|
|
index 9f305bb9c..3a9f420db 100644
|
|
--- a/readmsg/readmsg.c
|
|
+++ b/readmsg/readmsg.c
|
|
@@ -466,7 +466,7 @@ main (int argc, char **argv)
|
|
mu_mailbox_t mbox = NULL;
|
|
struct mu_wordsplit ws;
|
|
char **weedv;
|
|
- int weedc;
|
|
+ int weedc = 0;
|
|
int unix_header = 0;
|
|
|
|
/* Native Language Support */
|
|
--
|
|
2.28.0
|
|
|