mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-31 16:42:38 -05:00
29a780147d
* gnu/packages/patches/icecat-CVE-2016-1930-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt07.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt08.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt09.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt10.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt11.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt12.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt13.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt14.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt15.patch, gnu/packages/patches/icecat-CVE-2016-1935.patch, gnu/packages/patches/icecat-bug-1146335-pt1.patch, gnu/packages/patches/icecat-bug-1146335-pt2.patch, gnu/packages/patches/icecat-limit-max-buffers-size-for-ANGLE.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
51 lines
1.7 KiB
Diff
51 lines
1.7 KiB
Diff
Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/4f6e81673f69
|
|
Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2016-01/
|
|
Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1223670
|
|
|
|
# HG changeset patch
|
|
# User Karl Tomlinson <karlt+@karlt.net>
|
|
# Date 1449145091 -46800
|
|
# Node ID 4f6e81673f6938719c86516606f2fda493e8c23c
|
|
# Parent 6d43ff33bd552b8f7a34e4105cf5bcc0a8c8ea8c
|
|
bug 1223670 make SetMozAudioChannelType() private because the type will not change after construction r=baku a=abillings
|
|
|
|
diff --git a/dom/media/webaudio/AudioDestinationNode.h b/dom/media/webaudio/AudioDestinationNode.h
|
|
--- a/dom/media/webaudio/AudioDestinationNode.h
|
|
+++ b/dom/media/webaudio/AudioDestinationNode.h
|
|
@@ -57,17 +57,16 @@ public:
|
|
void StartRendering(Promise* aPromise);
|
|
|
|
void OfflineShutdown();
|
|
|
|
// nsIDOMEventListener - by proxy
|
|
NS_IMETHOD HandleEvent(nsIDOMEvent* aEvent) override;
|
|
|
|
AudioChannel MozAudioChannelType() const;
|
|
- void SetMozAudioChannelType(AudioChannel aValue, ErrorResult& aRv);
|
|
|
|
virtual void NotifyMainThreadStateChanged() override;
|
|
void FireOfflineCompletionEvent();
|
|
|
|
// An amount that should be added to the MediaStream's current time to
|
|
// get the AudioContext.currentTime.
|
|
double ExtraCurrentTime();
|
|
|
|
@@ -86,16 +85,17 @@ public:
|
|
|
|
void InputMuted(bool aInputMuted);
|
|
void ResolvePromise(AudioBuffer* aRenderedBuffer);
|
|
|
|
protected:
|
|
virtual ~AudioDestinationNode();
|
|
|
|
private:
|
|
+ void SetMozAudioChannelType(AudioChannel aValue, ErrorResult& aRv);
|
|
bool CheckAudioChannelPermissions(AudioChannel aValue);
|
|
|
|
void SetCanPlay(bool aCanPlay);
|
|
|
|
void NotifyStableState();
|
|
void ScheduleStableStateNotification();
|
|
|
|
SelfReference<AudioDestinationNode> mOfflineRenderingRef;
|
|
|