mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
4ac3df4290
* distro/base.scm (m4): New variable. * distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch: New files. * Makefile.am (nobase_dist_guilemodule_DATA): Add them.
18 lines
722 B
Diff
18 lines
722 B
Diff
Newer Linux kernels would return EINVAL instead of ENOENT.
|
|
The patch below, taken from Gnulib, allows the test to pass when
|
|
these Linux versions are in use:
|
|
https://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html .
|
|
|
|
diff --git a/tests/test-readlink.h b/tests/test-readlink.h
|
|
index 08d5662..7247fc4 100644
|
|
--- a/tests/test-readlink.h
|
|
+++ b/tests/test-readlink.h
|
|
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char const *, char *, size_t), bool print)
|
|
ASSERT (errno == ENOENT);
|
|
errno = 0;
|
|
ASSERT (func ("", buf, sizeof buf) == -1);
|
|
- ASSERT (errno == ENOENT);
|
|
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
|
errno = 0;
|
|
ASSERT (func (".", buf, sizeof buf) == -1);
|
|
ASSERT (errno == EINVAL);
|