mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
8495069bed
* gnu/packages/patches/scribus-1.5.8-poppler-22.03.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.04.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-1.patch, gnu/packages/patches/scribus-1.5.8-poppler-22.2.0-2.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/scribus.scm (scribus)[source]: Add patches. [arguments]: Enable WANT_CPP17 option.
20 lines
677 B
Diff
20 lines
677 B
Diff
--- a/scribus/plugins/import/pdf/slaoutput.cpp
|
|
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
|
|
@@ -3741,9 +3741,16 @@ void SlaOutputDev::getPenState(GfxState *state)
|
|
break;
|
|
}
|
|
double lw = state->getLineWidth();
|
|
- double *dashPattern;
|
|
int dashLength;
|
|
+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(22, 9, 0)
|
|
+ const double *dashPattern;
|
|
+ const std::vector<double> &dash = state->getLineDash(&DashOffset);
|
|
+ dashPattern = dash.data();
|
|
+ dashLength = dash.size();
|
|
+#else
|
|
+ double *dashPattern;
|
|
state->getLineDash(&dashPattern, &dashLength, &DashOffset);
|
|
+#endif
|
|
QVector<double> pattern(dashLength);
|
|
for (int i = 0; i < dashLength; ++i)
|
|
{
|