mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 03:15:09 -05:00
e1820d1443
* gnu/packages/patches/icecat-CVE-2015-0797.patch, gnu/packages/patches/icecat-CVE-2015-2708-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2708-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2708-pt3.patch, gnu/packages/patches/icecat-CVE-2015-2708-pt4.patch, gnu/packages/patches/icecat-CVE-2015-2710-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2710-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2710-pt3.patch, gnu/packages/patches/icecat-CVE-2015-2713-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2713-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2716.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat): Add patches.
26 lines
892 B
Diff
26 lines
892 B
Diff
From e6082e031f0fa2a4a7a63ff124c6f22aeb75393d Mon Sep 17 00:00:00 2001
|
|
From: Terrence Cole <terrence@mozilla.com>
|
|
Date: Fri, 10 Apr 2015 08:58:26 -0700
|
|
Subject: [PATCH] Bug 1152177 - Make jsid and Value pre barriers symetrical.
|
|
r=jonco, a=abillings
|
|
|
|
---
|
|
js/src/gc/Barrier.h | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/js/src/gc/Barrier.h b/js/src/gc/Barrier.h
|
|
index 7efd785..9fc6bd0 100644
|
|
--- a/js/src/gc/Barrier.h
|
|
+++ b/js/src/gc/Barrier.h
|
|
@@ -1062,6 +1062,8 @@ class BarrieredId
|
|
JS_ASSERT(obj == JSID_TO_OBJECT(value));
|
|
}
|
|
} else if (JSID_IS_STRING(value)) {
|
|
+ if (StringIsPermanentAtom(JSID_TO_STRING(value)))
|
|
+ return;
|
|
JSString *str = JSID_TO_STRING(value);
|
|
JS::shadow::Zone *shadowZone = ShadowZoneOfStringFromAnyThread(str);
|
|
if (shadowZone->needsBarrier()) {
|
|
--
|
|
2.2.1
|
|
|