mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
f2c6375449
* gnu/packages/patches/gcc-6-fix-buffer-size.patch: New file. * gnu/packages/patches/gcc-6-fix-isl-includes.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/embedded.scm (gcc-vc4): Update to commit 0fe4b83897341742f9df65797474cb0feab4b377. [source]: Add the patches from above.
16 lines
535 B
Diff
16 lines
535 B
Diff
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86724
|
|
Author: Rainer Jung
|
|
Date: 2018-07-29
|
|
|
|
isl 0.20 stopped including other unused header files in their header files.
|
|
Therefore,now it's necessary to include the stuff ourselves.
|
|
--- .../gcc/graphite.h 2018-01-03 11:03:58.000000000 +0000
|
|
+++ .../gcc/graphite.h 2018-07-29 17:42:55.836121000 +0000
|
|
@@ -37,6 +37,8 @@
|
|
#include <isl/schedule.h>
|
|
#include <isl/ast_build.h>
|
|
#include <isl/schedule_node.h>
|
|
+#include <isl/id.h>
|
|
+#include <isl/space.h>
|
|
|
|
typedef struct poly_dr *poly_dr_p;
|