mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
b78f0cbff4
* gnu/packages/patches/gtk-introspection-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gtk.scm (gtk): Update to 4.4.1. [origin]: Apply new patch. [phases]{pre-check}: Set TZDIR. [native-inputs]: Add graphene, python-pygobject and tzdata.
22 lines
918 B
Diff
22 lines
918 B
Diff
# Extend rather than stomp environment variables.
|
|
# Upstream status: https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/4268
|
|
diff --git a/testsuite/introspection/meson.build b/testsuite/introspection/meson.build
|
|
index 6202fb7446..b59191eb0f 100644
|
|
--- a/testsuite/introspection/meson.build
|
|
+++ b/testsuite/introspection/meson.build
|
|
@@ -1,9 +1,10 @@
|
|
+env = environment()
|
|
+env.prepend('GI_TYPELIB_PATH',
|
|
+ join_paths(project_build_root, 'gtk'),
|
|
+ gi_dep.get_pkgconfig_variable('typelibdir'))
|
|
+env.prepend('LD_PRELOAD', join_paths(project_build_root, 'gtk', 'libgtk-4.so'))
|
|
|
|
test('api',
|
|
find_program('api.py', dirs: meson.current_source_dir()),
|
|
suite: ['introspection'],
|
|
- env: [
|
|
- 'GI_TYPELIB_PATH=@0@/gtk:@1@'.format(project_build_root,
|
|
- gi_dep.get_pkgconfig_variable('typelibdir')),
|
|
- 'LD_PRELOAD=@0@/gtk/libgtk-4.so'.format(project_build_root),
|
|
- ])
|
|
+ env: env)
|