mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
ae3909eb4c
* gnu/packages/patches/python2-parameterized-docstring-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/check.scm (python-parameterized): Update to 0.7.1. [arguments]: Remove #:tests?. Add #:phases to override 'check' phase. [native-inputs]: Add PYTHON-MOCK and PYTHON-NOSE. [properties]: New field. (python2-parameterized)[source](patches): New field.
18 lines
588 B
Diff
18 lines
588 B
Diff
Skip unicode docstring test, required when running on Python 2.
|
|
|
|
See <https://github.com/wolever/parameterized/issues/44>.
|
|
|
|
--- a/parameterized/test.py
|
|
+++ b/parameterized/test.py
|
|
@@ -284,11 +284,6 @@
|
|
" More" %(foo, )
|
|
)
|
|
|
|
- @parameterized.expand([param("foo")])
|
|
- def test_unicode_docstring(self, foo):
|
|
- u"""Döcumentation."""
|
|
- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
|
|
-
|
|
@parameterized.expand([param("foo", )])
|
|
def test_default_values_get_correct_value(self, foo, bar=12):
|
|
"""Documentation"""
|