mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
610b395424
Fixes CVE-2024-45490, CVE-2024-45491, CVE-2024-45492. * gnu/packages/xml.scm (expat)[replacement]: New field. (expat/fixed): New variable. * gnu/packages/patches/expat-CVE-2024-45490.patch, gnu/packages/patches/expat-CVE-2024-45491.patch, gnu/packages/patches/expat-CVE-2024-45492.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them. Change-Id: I74d5d7bce98d6c983b989c1afec7cf28777d1617
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
https://github.com/libexpat/libexpat/commit/8e439a9947e9dc80a395c0c7456545d8d9d9e421.patch
|
|
Fixed in 2.6.3.
|
|
|
|
From 8e439a9947e9dc80a395c0c7456545d8d9d9e421 Mon Sep 17 00:00:00 2001
|
|
From: Sebastian Pipping <sebastian@pipping.org>
|
|
Date: Mon, 19 Aug 2024 22:34:13 +0200
|
|
Subject: [PATCH] lib: Detect integer overflow in dtdCopy
|
|
|
|
Reported by TaiYou
|
|
---
|
|
expat/lib/xmlparse.c | 10 ++++++++++
|
|
1 file changed, 10 insertions(+)
|
|
|
|
diff --git a/lib/xmlparse.c b/lib/xmlparse.c
|
|
index 91682c188..e2327bdcf 100644
|
|
--- a/lib/xmlparse.c
|
|
+++ b/lib/xmlparse.c
|
|
@@ -7016,6 +7016,16 @@ dtdCopy(XML_Parser oldParser, DTD *newDtd, const DTD *oldDtd,
|
|
if (! newE)
|
|
return 0;
|
|
if (oldE->nDefaultAtts) {
|
|
+ /* Detect and prevent integer overflow.
|
|
+ * The preprocessor guard addresses the "always false" warning
|
|
+ * from -Wtype-limits on platforms where
|
|
+ * sizeof(int) < sizeof(size_t), e.g. on x86_64. */
|
|
+#if UINT_MAX >= SIZE_MAX
|
|
+ if ((size_t)oldE->nDefaultAtts
|
|
+ > ((size_t)(-1) / sizeof(DEFAULT_ATTRIBUTE))) {
|
|
+ return 0;
|
|
+ }
|
|
+#endif
|
|
newE->defaultAtts
|
|
= ms->malloc_fcn(oldE->nDefaultAtts * sizeof(DEFAULT_ATTRIBUTE));
|
|
if (! newE->defaultAtts) {
|