guix/gnu/packages/patches/freeimage-libraw-0.21-compat.patch
Zheng Junjie e9b97b193a
gnu: freeimage: Adjust for libraw 0.21.
* gnu/packages/patches/freeimage-libraw-0.21-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/image.scm (freeimage)[source](patches): Add it.

Change-Id: Ief930d50be3e1f44074cd772756fb813bbad4389
2024-07-18 10:45:29 +08:00

15 lines
899 B
Diff

from https://gitlab.archlinux.org/archlinux/packaging/packages/freeimage/-/blob/69548d01896b32f30937a71220a9133055d84705/freeimage-libraw-0.21.patch
diff -ru FreeImage.orig/Source/FreeImage/PluginRAW.cpp FreeImage/Source/FreeImage/PluginRAW.cpp
--- FreeImage.orig/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:57:11.447801357 +0100
+++ FreeImage/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:58:05.103433138 +0100
@@ -687,7 +687,7 @@
// --------------------------------------------
// (-s [0..N-1]) Select one raw image from input file
- RawProcessor->imgdata.params.shot_select = 0;
+ RawProcessor->imgdata.rawparams.shot_select = 0;
// (-w) Use camera white balance, if possible (otherwise, fallback to auto_wb)
RawProcessor->imgdata.params.use_camera_wb = 1;
// (-M) Use any color matrix from the camera metadata. This option only affects Olympus, Leaf, and Phase One cameras.