mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 19:35:25 -05:00
253fc14777
* gnu/packages/patches/nftables-fix-makefile.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/linux.scm (nftables): Update to 1.0.2. [source]: Add patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
|
|
From: Pablo Neira Ayuso <pablo@netfilter.org>
|
|
Date: Tue, 22 Feb 2022 00:56:36 +0100
|
|
Subject: examples: compile with `make check' and add AM_CPPFLAGS
|
|
|
|
Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
|
|
specify local headers via -I.
|
|
|
|
Unfortunately, `make distcheck' did not catch this compile time error in
|
|
my system, since it was using the nftables/libnftables.h file of the
|
|
previous nftables release.
|
|
|
|
Fixes: 5b364657a35f ("build: missing SUBIRS update")
|
|
Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
|
|
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
|
---
|
|
examples/Makefile.am | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/examples/Makefile.am b/examples/Makefile.am
|
|
index c972170d..3b8b0b67 100644
|
|
--- a/examples/Makefile.am
|
|
+++ b/examples/Makefile.am
|
|
@@ -1,4 +1,6 @@
|
|
-noinst_PROGRAMS = nft-buffer \
|
|
+check_PROGRAMS = nft-buffer \
|
|
nft-json-file
|
|
|
|
+AM_CPPFLAGS = -I$(top_srcdir)/include
|
|
+
|
|
LDADD = $(top_builddir)/src/libnftables.la
|
|
--
|
|
cgit v1.2.3
|
|
|