mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-13 18:36:14 -05:00
ddab5244df
* gnu/packages/c.scm (aws-c-event-stream): New variable. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
13 lines
338 B
Diff
13 lines
338 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -3,6 +3,10 @@
|
|
cmake_minimum_required (VERSION 3.1)
|
|
project (aws-c-event-stream C)
|
|
|
|
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
|
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
|
+endif()
|
|
+
|
|
if (DEFINED CMAKE_PREFIX_PATH)
|
|
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
|
endif()
|