mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-13 18:36:14 -05:00
9dd9e8fabf
* gnu/packages/patches/fontconfig-hurd-path-max.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/fontutils.scm (fontconfig): Use it.
17 lines
482 B
Diff
17 lines
482 B
Diff
Avoid usage of PATH_MAX.
|
|
|
|
Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
|
|
|
|
Index: fontconfig-2.13.1/src/fccfg.c
|
|
===================================================================
|
|
--- fontconfig-2.13.1.orig/src/fccfg.c
|
|
+++ fontconfig-2.13.1/src/fccfg.c
|
|
@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
|
|
|
|
if (n)
|
|
{
|
|
- FcChar8 buf[PATH_MAX];
|
|
+ FcChar8 buf[FC_PATH_MAX];
|
|
ssize_t len;
|
|
|
|
if (sysroot)
|