mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
015777f4c5
* gnu/packages/patches/esmini-no-clutter-log.patch: New file. * gnu/packages/patches/esmini-use-pkgconfig.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them here. * gnu/packages/simulation.scm (esmini): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
30 lines
1.1 KiB
Diff
30 lines
1.1 KiB
Diff
Don't clutter /tmp with logs.
|
|
|
|
---
|
|
EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp | 10 ++--------
|
|
1 file changed, 2 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
|
|
index 56c655dc..2750f5a6 100644
|
|
--- a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
|
|
+++ b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
|
|
@@ -1013,14 +1013,8 @@ void Logger::OpenLogfile(std::string filename)
|
|
file_.open(filename.c_str());
|
|
if (file_.fail())
|
|
{
|
|
- const char* filename_tmp = std::tmpnam(NULL);
|
|
- printf("Cannot open log file: %s in working directory. Trying system tmp-file: %s\n",
|
|
- SE_Env::Inst().GetLogFilePath().c_str(), filename_tmp);
|
|
- file_.open(filename_tmp);
|
|
- if (file_.fail())
|
|
- {
|
|
- printf("Also failed to open log file: %s. Continue without logfile, still logging to console.\n", filename_tmp);
|
|
- }
|
|
+ printf("Cannot open log file: %s in working directory. Continuing without logfile, still logging to console.\n",
|
|
+ filename.c_str());
|
|
}
|
|
}
|
|
#endif
|
|
--
|
|
2.38.1
|
|
|