mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
5c0f77f424
Fixes <https://issues.guix.gnu.org/68333>. * gnu/packages/java.scm (icedtea-7)[drop]: Add optional ‘patches’ parameter and honor it. [native-inputs]: Add patch for “jdk-drop”. (icedtea-8): Likewise. * gnu/packages/patches/jdk-currency-time-bomb.patch, gnu/packages/patches/jdk-currency-time-bomb2.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Change-Id: I3b4cf562ce4bedb87ce0e7c289e431fbb0dbb6f8
13 lines
861 B
Diff
13 lines
861 B
Diff
Fix a time bomb present in the jdk "drop" of IcedTea 8.
|
|
|
|
--- a/make/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
|
|
+++ b/make/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
|
|
@@ -284,7 +284,7 @@ public class GenerateCurrencyData {
|
|
String timeString = currencyInfo.substring(4, length - 4);
|
|
long time = format.parse(timeString).getTime();
|
|
if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
|
|
- throw new RuntimeException("time is more than 10 years from present: " + time);
|
|
+ System.err.println("note: time is more than 10 years from \"present\": " + time);
|
|
}
|
|
specialCaseCutOverTimes[specialCaseCount] = time;
|
|
specialCaseOldCurrencies[specialCaseCount] = oldCurrency;
|