mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
a8e149434e
Patches should fix all CVEs reported by `guix lint`: CVE-2015-7747; CVE-2017-6827, CVE-2017-6828, CVE-2017-6829, CVE-2017-6830, CVE-2017-6831, CVE-2017-6832, CVE-2017-6833, CVE-2017-6834, CVE-2017-6835, CVE-2017-6836, CVE-2017-6837, CVE-2017-6838, CVE-2017-6839; CVE-2018-13440; CVE-2018-17095 Since the patches do not reference to CVEs, it's a bit hard to tell which patch actually closes which CVE. Debian reports all these to be closed by the patches below and NixPkgs provides references. * gnu/packages/audio.scm (audiofile): New variable. * gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch, gnu/packages/patches/audiofile-fix-sign-conversion.patch, gnu/packages/patches/audiofile-CVE-2015-7747.patch, gnu/packages/patches/audiofile-CVE-2018-13440.patch, gnu/packages/patches/audiofile-CVE-2018-17095.patch, gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch, gnu/packages/patches/audiofile-Fail-on-error-in-parseFormat.patch, gnu/packages/patches/audiofile-Fix-index-overflow-in-IMA.cpp.patch, gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch, gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch, gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch, gnu/packages/patches/audiofile-hurd.patch, gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: New files. * gnu/local.mk: Add them.
30 lines
947 B
Diff
30 lines
947 B
Diff
From: Antonio Larrosa <larrosa@kde.org>
|
|
Date: Mon, 6 Mar 2017 12:51:22 +0100
|
|
Subject: Always check the number of coefficients
|
|
|
|
When building the library with NDEBUG, asserts are eliminated
|
|
so it's better to always check that the number of coefficients
|
|
is inside the array range.
|
|
|
|
This fixes the 00191-audiofile-indexoob issue in #41
|
|
---
|
|
libaudiofile/WAVE.cpp | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp
|
|
index 9dd8511..0fc48e8 100644
|
|
--- a/libaudiofile/WAVE.cpp
|
|
+++ b/libaudiofile/WAVE.cpp
|
|
@@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size)
|
|
|
|
/* numCoefficients should be at least 7. */
|
|
assert(numCoefficients >= 7 && numCoefficients <= 255);
|
|
+ if (numCoefficients < 7 || numCoefficients > 255)
|
|
+ {
|
|
+ _af_error(AF_BAD_HEADER,
|
|
+ "Bad number of coefficients");
|
|
+ return AF_FAIL;
|
|
+ }
|
|
|
|
m_msadpcmNumCoefficients = numCoefficients;
|
|
|