mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
38988dbecf
* gnu/packages/kde.scm(kpmcore): Update to 4.0.1. [origin]: Add upstream patches for making tests pass. [inputs]: Add qttools. Remove kiconthemes, kservice, libatasmart, parted. [arguments]: New element. * gnu/packages/patches/kpmcore-fix-tests.patch, gnu/packages/patches/kpmcore-remove-broken-test.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. add patches
30 lines
1.1 KiB
Diff
30 lines
1.1 KiB
Diff
Git commit c02d59aa6d314678cef9683f96b28e2a1abd82b7 by Andrius Štikonas, on behalf of Hartmut Goebel.
|
|
Committed on 07/11/2019 at 22:16.
|
|
Pushed by stikonas into branch '4.0'.
|
|
|
|
Fix test for kpmcore: stop helper only if formerly started.
|
|
|
|
See https://bugs.kde.org/413851 and https://phabricator.kde.org/D25161
|
|
|
|
diff --git a/src/util/externalcommand.cpp b/src/util/externalcommand.cpp
|
|
--- a/src/util/externalcommand.cpp
|
|
+++ b/src/util/externalcommand.cpp
|
|
@@ -433,14 +433,17 @@
|
|
|
|
void ExternalCommand::stopHelper()
|
|
{
|
|
+ if (!helperStarted)
|
|
+ return;
|
|
auto *interface = new org::kde::kpmcore::externalcommand(QStringLiteral("org.kde.kpmcore.externalcommand"),
|
|
QStringLiteral("/Helper"), QDBusConnection::systemBus());
|
|
QByteArray request;
|
|
const quint64 nonce = interface->getNonce();
|
|
request.setNum(nonce);
|
|
QByteArray hash = QCryptographicHash::hash(request, QCryptographicHash::Sha512);
|
|
interface->exit(privateKey->signMessage(hash, QCA::EMSA3_Raw), nonce);
|
|
|
|
+ helperStarted = false;
|
|
delete privateKey;
|
|
delete init;
|
|
}
|
|
|