mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
72a91d74ce
* gnu/packages/virtualization.scm (system->qemu-target, ganeti): New variables. * gnu/packages/patches/ganeti-deterministic-manual.patch, gnu/packages/patches/ganeti-disable-version-symlinks.patch, gnu/packages/patches/ganeti-drbd-compat.patch, gnu/packages/patches/ganeti-haskell-pythondir.patch, gnu/packages/patches/ganeti-os-disk-size.patch, gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch, gnu/packages/patches/ganeti-shepherd-master-failover.patch, gnu/packages/patches/ganeti-shepherd-support.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
16 lines
559 B
Diff
16 lines
559 B
Diff
Sort the ecode list in the gnt-cluster manual for deterministic results.
|
|
|
|
Submitted upstream: <https://github.com/ganeti/ganeti/pull/1504>.
|
|
|
|
diff --git a/lib/build/sphinx_ext.py b/lib/build/sphinx_ext.py
|
|
--- a/lib/build/sphinx_ext.py
|
|
+++ b/lib/build/sphinx_ext.py
|
|
@@ -108,7 +108,7 @@ CV_ECODES_DOC = "ecodes"
|
|
# pylint: disable=W0621
|
|
CV_ECODES_DOC_LIST = [(name, doc) for (_, name, doc) in constants.CV_ALL_ECODES]
|
|
DOCUMENTED_CONSTANTS = {
|
|
- CV_ECODES_DOC: CV_ECODES_DOC_LIST,
|
|
+ CV_ECODES_DOC: sorted(CV_ECODES_DOC_LIST, key=lambda tup: tup[0]),
|
|
}
|
|
|
|
|