mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
72a91d74ce
* gnu/packages/virtualization.scm (system->qemu-target, ganeti): New variables. * gnu/packages/patches/ganeti-deterministic-manual.patch, gnu/packages/patches/ganeti-disable-version-symlinks.patch, gnu/packages/patches/ganeti-drbd-compat.patch, gnu/packages/patches/ganeti-haskell-pythondir.patch, gnu/packages/patches/ganeti-os-disk-size.patch, gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch, gnu/packages/patches/ganeti-shepherd-master-failover.patch, gnu/packages/patches/ganeti-shepherd-support.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
21 lines
855 B
Diff
21 lines
855 B
Diff
Do not override PYTHONPATH when calling Python code from the Haskell
|
|
daemons. This is necessary because the Python library dependencies are
|
|
only available through PYTHONPATH.
|
|
|
|
diff --git a/src/Ganeti/Query/Exec.hs b/src/Ganeti/Query/Exec.hs
|
|
--- a/src/Ganeti/Query/Exec.hs
|
|
+++ b/src/Ganeti/Query/Exec.hs
|
|
@@ -99,12 +99,10 @@ spawnJobProcess jid = withErrorLogAt CRITICAL (show jid) $
|
|
do
|
|
use_debug <- isDebugMode
|
|
env_ <- (M.toList . M.insert "GNT_DEBUG" (if use_debug then "1" else "0")
|
|
- . M.insert "PYTHONPATH" AC.pythondir
|
|
. M.fromList)
|
|
`liftM` getEnvironment
|
|
execPy <- P.jqueueExecutorPy
|
|
logDebug $ "Executing " ++ AC.pythonPath ++ " " ++ execPy
|
|
- ++ " with PYTHONPATH=" ++ AC.pythondir
|
|
|
|
(master, child) <- pipeClient connectConfig
|
|
let (rh, wh) = clientToHandle child
|
|
|