mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
db87a223fe
* gnu/packages/patches/brightnessctl-elogind-support.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/linux.scm (brightnessctl)[source]: Apply it. [make-flags]: Enable logind support. [native-inputs]: Add pkg-config. [inputs]: Add elogind.
13 lines
440 B
Diff
13 lines
440 B
Diff
From https://github.com/Hummer12007/brightnessctl/issues/67
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -18,6 +18,8 @@ MODE = ${MODE_${INSTALL_UDEV_RULES}}
|
|
ifdef ENABLE_SYSTEMD
|
|
CFLAGS += ${shell pkg-config --cflags libsystemd}
|
|
LDLIBS += ${shell pkg-config --libs libsystemd}
|
|
+ CFLAGS += ${shell pkg-config --cflags libelogind}
|
|
+ LDLIBS += ${shell pkg-config --libs libelogind}
|
|
CPPFLAGS += -DENABLE_SYSTEMD
|
|
INSTALL_UDEV_RULES=0
|
|
MODE = 0755
|