mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
2073b55e6b
Fixes <https://bugs.gnu.org/30756>. Initially reported by Julien Lepiller <julien@lepiller.eu>. * gnu/packages/base.scm (make-gcc-libc): Remove 'treat-glibc-as-system-header' phase from 'arguments'. * gnu/packages/commencement.scm (gcc-final): Likewise. * gnu/packages/gcc.scm (gcc-4.7)[arguments]: Add "include/c++" to 'CPLUS_INCLUDE_PATH'. (gcc-6)[native-search-paths]: Remove. * gnu/packages/make-bootstrap.scm (gcc-for-bootstrap): Remove 'native-search-paths' and 'arguments'. * gnu/packages/patches/python-2.7-search-paths.patch, gnu/packages/patches/python-3-search-paths.patch: Replace "CPATH" with "C_INCLUDE_PATH". * guix/build-system/cmake.scm (lower): When not cross-compiling, move INPUTS from the 'host-inputs' field to the 'build-inputs' field of the bag, right after NATIVE-INPUTS. * guix/build-system/glib-or-gtk.scm (lower): Likewise. * guix/build-system/gnu.scm (lower): Likewise. * guix/build-system/meson.scm (lower): Likewise.
20 lines
1,001 B
Diff
20 lines
1,001 B
Diff
Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
|
|
looking for headers and libraries.
|
|
|
|
--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
|
|
+++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200
|
|
@@ -526,6 +526,14 @@ class PyBuildExt(build_ext):
|
|
inc_dirs += ['/system/include', '/atheos/autolnk/include']
|
|
inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
|
|
|
|
+ # Always honor these variables.
|
|
+ if not cross_compiling:
|
|
+ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
|
|
+ else:
|
|
+ lib_dirs = os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs = os.getenv('CROSS_CPATH', '').split(os.pathsep)
|
|
+
|
|
# OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
|
|
if host_platform in ['osf1', 'unixware7', 'openunix8']:
|
|
lib_dirs += ['/usr/ccs/lib']
|