mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
b5c4f5d9ee
* gnu/packages/python.scm (python-3.8): Rename to... (python-3.9): ... this. Update version to 3.9.1. [arguments]{make-flags}: Restore test_socket test. [phases]{unset-SOURCE_DATE_EPOCH, reset-SOURCE_DATE_EPOCH}: Remove phases. {rebuild-bytecode}: Simplify code. Set the invalidation-mode argument of the compileall module to "unchecked-hash", to ensure determinism. (python-3): Adjust to refer to python-3.9. * gnu/packages/patches/python-3-fix-tests.patch: Rebase and extend patch. * gnu/packages/patches/python-3.8-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
415 lines
18 KiB
Diff
415 lines
18 KiB
Diff
From f0698133e7d6c353a3e6ae0fc62e57ba558a9bc0 Mon Sep 17 00:00:00 2001
|
|
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
|
Date: Wed, 28 Oct 2020 22:55:05 -0400
|
|
Subject: [PATCH] Skip problematic Python 3 tests in Guix.
|
|
|
|
A subset of the hunks in this patch is tracked upstream at
|
|
https://bugs.python.org/issue38845, which was contributed by Tanguy Le
|
|
Carrour <tanguy@bioneland.org>.
|
|
---
|
|
Lib/ctypes/test/test_callbacks.py | 3 +++
|
|
Lib/ctypes/test/test_find.py | 1 +
|
|
Lib/ctypes/test/test_libc.py | 3 +++
|
|
Lib/distutils/tests/test_archive_util.py | 2 ++
|
|
Lib/distutils/tests/test_sdist.py | 1 +
|
|
Lib/test/_test_multiprocessing.py | 2 ++
|
|
Lib/test/test_asyncio/test_base_events.py | 2 ++
|
|
Lib/test/test_generators.py | 1 +
|
|
Lib/test/test_pathlib.py | 3 +--
|
|
Lib/test/test_pdb.py | 4 ++--
|
|
Lib/test/test_regrtest.py | 2 ++
|
|
Lib/test/test_resource.py | 1 +
|
|
Lib/test/test_shutil.py | 2 ++
|
|
Lib/test/test_signal.py | 4 ++++
|
|
Lib/test/test_socket.py | 8 ++++++++
|
|
Lib/test/test_spwd.py | 6 ++----
|
|
Lib/test/test_tarfile.py | 9 ++++++---
|
|
Lib/test/test_threading.py | 3 +++
|
|
Lib/test/test_unicodedata.py | 1 +
|
|
Tools/scripts/run_tests.py | 2 +-
|
|
20 files changed, 48 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/Lib/ctypes/test/test_callbacks.py b/Lib/ctypes/test/test_callbacks.py
|
|
index d8e9c5a760..94fc5929c9 100644
|
|
--- a/Lib/ctypes/test/test_callbacks.py
|
|
+++ b/Lib/ctypes/test/test_callbacks.py
|
|
@@ -5,6 +5,7 @@ from test import support
|
|
from ctypes import *
|
|
from ctypes.test import need_symbol
|
|
import _ctypes_test
|
|
+import platform
|
|
|
|
class Callbacks(unittest.TestCase):
|
|
functype = CFUNCTYPE
|
|
@@ -178,6 +179,8 @@ class SampleCallbacksTestCase(unittest.TestCase):
|
|
|
|
self.assertLess(diff, 0.01, "%s not less than 0.01" % diff)
|
|
|
|
+ @unittest.skipIf(platform.machine() in ['mips64'],
|
|
+ "This test fails on this platform")
|
|
def test_issue_8959_a(self):
|
|
from ctypes.util import find_library
|
|
libc_path = find_library("c")
|
|
diff --git a/Lib/ctypes/test/test_find.py b/Lib/ctypes/test/test_find.py
|
|
index 92ac1840ad..c8eb75dedd 100644
|
|
--- a/Lib/ctypes/test/test_find.py
|
|
+++ b/Lib/ctypes/test/test_find.py
|
|
@@ -116,6 +116,7 @@ class FindLibraryLinux(unittest.TestCase):
|
|
with unittest.mock.patch("ctypes.util._findSoname_ldconfig", lambda *args: None):
|
|
self.assertNotEqual(find_library('c'), None)
|
|
|
|
+ @unittest.skipIf(True, "ldconfig is not used on Guix")
|
|
def test_find_library_with_ld(self):
|
|
with unittest.mock.patch("ctypes.util._findSoname_ldconfig", lambda *args: None), \
|
|
unittest.mock.patch("ctypes.util._findLib_gcc", lambda *args: None):
|
|
diff --git a/Lib/ctypes/test/test_libc.py b/Lib/ctypes/test/test_libc.py
|
|
index 56285b5ff8..c088ab3db8 100644
|
|
--- a/Lib/ctypes/test/test_libc.py
|
|
+++ b/Lib/ctypes/test/test_libc.py
|
|
@@ -2,6 +2,7 @@ import unittest
|
|
|
|
from ctypes import *
|
|
import _ctypes_test
|
|
+import platform
|
|
|
|
lib = CDLL(_ctypes_test.__file__)
|
|
|
|
@@ -17,6 +18,8 @@ class LibTest(unittest.TestCase):
|
|
import math
|
|
self.assertEqual(lib.my_sqrt(2.0), math.sqrt(2.0))
|
|
|
|
+ @unittest.skipIf(platform.machine() in ['mips64'],
|
|
+ "This test fails on this platform")
|
|
def test_qsort(self):
|
|
comparefunc = CFUNCTYPE(c_int, POINTER(c_char), POINTER(c_char))
|
|
lib.my_qsort.argtypes = c_void_p, c_size_t, c_size_t, comparefunc
|
|
diff --git a/Lib/distutils/tests/test_archive_util.py b/Lib/distutils/tests/test_archive_util.py
|
|
index e9aad0e40f..8bbaa51ee5 100644
|
|
--- a/Lib/distutils/tests/test_archive_util.py
|
|
+++ b/Lib/distutils/tests/test_archive_util.py
|
|
@@ -333,6 +333,7 @@ class ArchiveUtilTestCase(support.TempdirManager,
|
|
self.assertEqual(os.path.basename(res), 'archive.tar.xz')
|
|
self.assertEqual(self._tarinfo(res), self._created_files)
|
|
|
|
+ @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
|
|
def test_make_archive_owner_group(self):
|
|
# testing make_archive with owner and group, with various combinations
|
|
# this works even if there's not gid/uid support
|
|
@@ -362,6 +363,7 @@ class ArchiveUtilTestCase(support.TempdirManager,
|
|
|
|
@unittest.skipUnless(ZLIB_SUPPORT, "Requires zlib")
|
|
@unittest.skipUnless(UID_GID_SUPPORT, "Requires grp and pwd support")
|
|
+ @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
|
|
def test_tarfile_root_owner(self):
|
|
tmpdir = self._create_files()
|
|
base_name = os.path.join(self.mkdtemp(), 'archive')
|
|
diff --git a/Lib/distutils/tests/test_sdist.py b/Lib/distutils/tests/test_sdist.py
|
|
index 23db126959..6e2329df7d 100644
|
|
--- a/Lib/distutils/tests/test_sdist.py
|
|
+++ b/Lib/distutils/tests/test_sdist.py
|
|
@@ -443,6 +443,7 @@ class SDistTestCase(BasePyPIRCCommandTestCase):
|
|
"The tar command is not found")
|
|
@unittest.skipIf(find_executable('gzip') is None,
|
|
"The gzip command is not found")
|
|
+ @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
|
|
def test_make_distribution_owner_group(self):
|
|
# now building a sdist
|
|
dist, cmd = self.get_cmd()
|
|
diff --git a/Lib/test/_test_multiprocessing.py b/Lib/test/_test_multiprocessing.py
|
|
index e47905c863..31a5a9c308 100644
|
|
--- a/Lib/test/_test_multiprocessing.py
|
|
+++ b/Lib/test/_test_multiprocessing.py
|
|
@@ -1577,6 +1577,7 @@ class _TestCondition(BaseTestCase):
|
|
if pid is not None:
|
|
os.kill(pid, signal.SIGINT)
|
|
|
|
+ @unittest.skipIf(True, "This fails for unknown reasons on Guix")
|
|
def test_wait_result(self):
|
|
if isinstance(self, ProcessesMixin) and sys.platform != 'win32':
|
|
pid = os.getpid()
|
|
@@ -3905,6 +3906,7 @@ class _TestSharedMemory(BaseTestCase):
|
|
sms.close()
|
|
|
|
@unittest.skipIf(os.name != "posix", "not feasible in non-posix platforms")
|
|
+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
|
|
def test_shared_memory_SharedMemoryServer_ignores_sigint(self):
|
|
# bpo-36368: protect SharedMemoryManager server process from
|
|
# KeyboardInterrupt signals.
|
|
diff --git a/Lib/test/test_asyncio/test_base_events.py b/Lib/test/test_asyncio/test_base_events.py
|
|
index 533d5cc7f5..c4f860cc3b 100644
|
|
--- a/Lib/test/test_asyncio/test_base_events.py
|
|
+++ b/Lib/test/test_asyncio/test_base_events.py
|
|
@@ -1341,6 +1341,8 @@ class BaseEventLoopWithSelectorTests(test_utils.TestCase):
|
|
self._test_create_connection_ip_addr(m_socket, False)
|
|
|
|
@patch_socket
|
|
+ @unittest.skipUnless(support.is_resource_enabled('network'),
|
|
+ 'network is not enabled')
|
|
def test_create_connection_service_name(self, m_socket):
|
|
m_socket.getaddrinfo = socket.getaddrinfo
|
|
sock = m_socket.socket.return_value
|
|
diff --git a/Lib/test/test_generators.py b/Lib/test/test_generators.py
|
|
index 3bf1522808..04bac8a7db 100644
|
|
--- a/Lib/test/test_generators.py
|
|
+++ b/Lib/test/test_generators.py
|
|
@@ -33,6 +33,7 @@ class SignalAndYieldFromTest(unittest.TestCase):
|
|
else:
|
|
return "FAILED"
|
|
|
|
+ @unittest.skipIf(True, 'Keyboard interrupts do not work in the Guix build environment')
|
|
def test_raise_and_yield_from(self):
|
|
gen = self.generator1()
|
|
gen.send(None)
|
|
diff --git a/Lib/test/test_pathlib.py b/Lib/test/test_pathlib.py
|
|
index 3da35710b9..5404f9193d 100644
|
|
--- a/Lib/test/test_pathlib.py
|
|
+++ b/Lib/test/test_pathlib.py
|
|
@@ -2408,8 +2408,7 @@ class PosixPathTest(_BasePathTest, unittest.TestCase):
|
|
self.assertEqual(given, expect)
|
|
self.assertEqual(set(p.rglob("FILEd*")), set())
|
|
|
|
- @unittest.skipUnless(hasattr(pwd, 'getpwall'),
|
|
- 'pwd module does not expose getpwall()')
|
|
+ @unittest.skipIf(True, "Guix builder home is '/' which causes trouble for these tests")
|
|
def test_expanduser(self):
|
|
P = self.cls
|
|
support.import_module('pwd')
|
|
diff --git a/Lib/test/test_pdb.py b/Lib/test/test_pdb.py
|
|
index 8016f81e5a..10190486b4 100644
|
|
--- a/Lib/test/test_pdb.py
|
|
+++ b/Lib/test/test_pdb.py
|
|
@@ -1219,11 +1219,11 @@ def test_pdb_issue_20766():
|
|
> <doctest test.test_pdb.test_pdb_issue_20766[0]>(6)test_function()
|
|
-> print('pdb %d: %s' % (i, sess._previous_sigint_handler))
|
|
(Pdb) continue
|
|
- pdb 1: <built-in function default_int_handler>
|
|
+ pdb 1: Handlers.SIG_IGN
|
|
> <doctest test.test_pdb.test_pdb_issue_20766[0]>(5)test_function()
|
|
-> sess.set_trace(sys._getframe())
|
|
(Pdb) continue
|
|
- pdb 2: <built-in function default_int_handler>
|
|
+ pdb 2: Handlers.SIG_IGN
|
|
"""
|
|
|
|
|
|
diff --git a/Lib/test/test_regrtest.py b/Lib/test/test_regrtest.py
|
|
index a77638b10a..2069b349a8 100644
|
|
--- a/Lib/test/test_regrtest.py
|
|
+++ b/Lib/test/test_regrtest.py
|
|
@@ -811,6 +811,7 @@ class ArgsTestCase(BaseTestCase):
|
|
output = self.run_tests('--fromfile', filename)
|
|
self.check_executed_tests(output, tests)
|
|
|
|
+ @unittest.skipIf(True, 'Keyboard interrupts do not work in the Guix build environment.')
|
|
def test_interrupted(self):
|
|
code = TEST_INTERRUPTED
|
|
test = self.create_test('sigint', code=code)
|
|
@@ -828,6 +829,7 @@ class ArgsTestCase(BaseTestCase):
|
|
% (self.TESTNAME_REGEX, len(tests)))
|
|
self.check_line(output, regex)
|
|
|
|
+ @unittest.skipIf(True, 'Keyboard interrupts do not work in the Guix build environment.')
|
|
def test_slowest_interrupted(self):
|
|
# Issue #25373: test --slowest with an interrupted test
|
|
code = TEST_INTERRUPTED
|
|
diff --git a/Lib/test/test_resource.py b/Lib/test/test_resource.py
|
|
index e5ece5284c..5299e54507 100644
|
|
--- a/Lib/test/test_resource.py
|
|
+++ b/Lib/test/test_resource.py
|
|
@@ -148,6 +148,7 @@ class ResourceTest(unittest.TestCase):
|
|
|
|
@unittest.skipUnless(hasattr(resource, 'prlimit'), 'no prlimit')
|
|
@support.requires_linux_version(2, 6, 36)
|
|
+ @unittest.skipIf(True, "Bug: the PermissionError is not raised")
|
|
def test_prlimit(self):
|
|
self.assertRaises(TypeError, resource.prlimit)
|
|
self.assertRaises(ProcessLookupError, resource.prlimit,
|
|
diff --git a/Lib/test/test_shutil.py b/Lib/test/test_shutil.py
|
|
index e19af64be0..1b893df6fa 100644
|
|
--- a/Lib/test/test_shutil.py
|
|
+++ b/Lib/test/test_shutil.py
|
|
@@ -1427,6 +1427,7 @@ class TestArchives(BaseTest, unittest.TestCase):
|
|
base_name = os.path.join(tmpdir, 'archive')
|
|
self.assertRaises(ValueError, make_archive, base_name, 'xxx')
|
|
|
|
+ @unittest.skipIf(True, "The Guix build container has no root user")
|
|
@support.requires_zlib()
|
|
def test_make_archive_owner_group(self):
|
|
# testing make_archive with owner and group, with various combinations
|
|
@@ -1455,6 +1456,7 @@ class TestArchives(BaseTest, unittest.TestCase):
|
|
self.assertTrue(os.path.isfile(res))
|
|
|
|
|
|
+ @unittest.skipIf(True, "The Guix build container has no root user")
|
|
@support.requires_zlib()
|
|
@unittest.skipUnless(UID_GID_SUPPORT, "Requires grp and pwd support")
|
|
def test_tarfile_root_owner(self):
|
|
diff --git a/Lib/test/test_signal.py b/Lib/test/test_signal.py
|
|
index 45553a6a42..55623f01a3 100644
|
|
--- a/Lib/test/test_signal.py
|
|
+++ b/Lib/test/test_signal.py
|
|
@@ -78,6 +78,7 @@ class PosixTests(unittest.TestCase):
|
|
self.assertLess(len(s), signal.NSIG)
|
|
|
|
@unittest.skipUnless(sys.executable, "sys.executable required.")
|
|
+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
|
|
def test_keyboard_interrupt_exit_code(self):
|
|
"""KeyboardInterrupt triggers exit via SIGINT."""
|
|
process = subprocess.run(
|
|
@@ -128,6 +129,7 @@ class WindowsSignalTests(unittest.TestCase):
|
|
signal.signal(7, handler)
|
|
|
|
@unittest.skipUnless(sys.executable, "sys.executable required.")
|
|
+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
|
|
def test_keyboard_interrupt_exit_code(self):
|
|
"""KeyboardInterrupt triggers an exit using STATUS_CONTROL_C_EXIT."""
|
|
# We don't test via os.kill(os.getpid(), signal.CTRL_C_EVENT) here
|
|
@@ -1245,6 +1247,7 @@ class StressTest(unittest.TestCase):
|
|
|
|
class RaiseSignalTest(unittest.TestCase):
|
|
|
|
+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
|
|
def test_sigint(self):
|
|
with self.assertRaises(KeyboardInterrupt):
|
|
signal.raise_signal(signal.SIGINT)
|
|
@@ -1275,6 +1278,7 @@ class RaiseSignalTest(unittest.TestCase):
|
|
|
|
class PidfdSignalTest(unittest.TestCase):
|
|
|
|
+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
|
|
@unittest.skipUnless(
|
|
hasattr(signal, "pidfd_send_signal"),
|
|
"pidfd support not built in",
|
|
diff --git a/Lib/test/test_socket.py b/Lib/test/test_socket.py
|
|
index aefba4f397..6c89f558d5 100755
|
|
--- a/Lib/test/test_socket.py
|
|
+++ b/Lib/test/test_socket.py
|
|
@@ -1009,6 +1009,8 @@ class GeneralModuleTests(unittest.TestCase):
|
|
if not fqhn in all_host_names:
|
|
self.fail("Error testing host resolution mechanisms. (fqdn: %s, all: %s)" % (fqhn, repr(all_host_names)))
|
|
|
|
+ @unittest.skipUnless(support.is_resource_enabled('network'),
|
|
+ 'network is not enabled')
|
|
def test_host_resolution(self):
|
|
for addr in [socket_helper.HOSTv4, '10.0.0.1', '255.255.255.255']:
|
|
self.assertEqual(socket.gethostbyname(addr), addr)
|
|
@@ -1140,6 +1142,8 @@ class GeneralModuleTests(unittest.TestCase):
|
|
self.assertWarns(DeprecationWarning, socket.ntohs, k)
|
|
self.assertWarns(DeprecationWarning, socket.htons, k)
|
|
|
|
+ @unittest.skipUnless(os.path.exists("/etc/services"),
|
|
+ "getservbyname uses /etc/services, which is not in the chroot")
|
|
def testGetServBy(self):
|
|
eq = self.assertEqual
|
|
# Find one service that exists, then check all the related interfaces.
|
|
@@ -1489,6 +1493,8 @@ class GeneralModuleTests(unittest.TestCase):
|
|
raise
|
|
self.assertRaises(TypeError, s.ioctl, socket.SIO_LOOPBACK_FAST_PATH, None)
|
|
|
|
+ @unittest.skipUnless(os.path.exists("/etc/gai.conf"),
|
|
+ "getaddrinfo() will fail")
|
|
def testGetaddrinfo(self):
|
|
try:
|
|
socket.getaddrinfo('localhost', 80)
|
|
@@ -1571,6 +1577,8 @@ class GeneralModuleTests(unittest.TestCase):
|
|
# only IP addresses are allowed
|
|
self.assertRaises(OSError, socket.getnameinfo, ('mail.python.org',0), 0)
|
|
|
|
+ @unittest.skipUnless(os.path.exists("/etc/gai.conf"),
|
|
+ "getaddrinfo() will fail")
|
|
@unittest.skipUnless(support.is_resource_enabled('network'),
|
|
'network is not enabled')
|
|
def test_idna(self):
|
|
diff --git a/Lib/test/test_spwd.py b/Lib/test/test_spwd.py
|
|
index 07793c84c8..fec672bcbe 100644
|
|
--- a/Lib/test/test_spwd.py
|
|
+++ b/Lib/test/test_spwd.py
|
|
@@ -5,8 +5,7 @@ from test import support
|
|
spwd = support.import_module('spwd')
|
|
|
|
|
|
-@unittest.skipUnless(hasattr(os, 'geteuid') and os.geteuid() == 0,
|
|
- 'root privileges required')
|
|
+@unittest.skipUnless(os.path.exists("/etc/shadow"), 'spwd tests require /etc/shadow')
|
|
class TestSpwdRoot(unittest.TestCase):
|
|
|
|
def test_getspall(self):
|
|
@@ -56,8 +55,7 @@ class TestSpwdRoot(unittest.TestCase):
|
|
self.assertRaises(TypeError, spwd.getspnam, bytes_name)
|
|
|
|
|
|
-@unittest.skipUnless(hasattr(os, 'geteuid') and os.geteuid() != 0,
|
|
- 'non-root user required')
|
|
+@unittest.skipUnless(os.path.exists("/etc/shadow"), 'spwd tests require /etc/shadow')
|
|
class TestSpwdNonRoot(unittest.TestCase):
|
|
|
|
def test_getspnam_exception(self):
|
|
diff --git a/Lib/test/test_tarfile.py b/Lib/test/test_tarfile.py
|
|
index 29cde91bf7..8d0f20e8bf 100644
|
|
--- a/Lib/test/test_tarfile.py
|
|
+++ b/Lib/test/test_tarfile.py
|
|
@@ -2607,9 +2607,12 @@ def root_is_uid_gid_0():
|
|
import pwd, grp
|
|
except ImportError:
|
|
return False
|
|
- if pwd.getpwuid(0)[0] != 'root':
|
|
- return False
|
|
- if grp.getgrgid(0)[0] != 'root':
|
|
+ try:
|
|
+ if pwd.getpwuid(0)[0] != 'root':
|
|
+ return False
|
|
+ if grp.getgrgid(0)[0] != 'root':
|
|
+ return False
|
|
+ except KeyError:
|
|
return False
|
|
return True
|
|
|
|
diff --git a/Lib/test/test_threading.py b/Lib/test/test_threading.py
|
|
index c21cdf8eb7..6c9d575032 100644
|
|
--- a/Lib/test/test_threading.py
|
|
+++ b/Lib/test/test_threading.py
|
|
@@ -1398,6 +1398,7 @@ class MiscTestCase(unittest.TestCase):
|
|
|
|
|
|
class InterruptMainTests(unittest.TestCase):
|
|
+ @unittest.skipIf(True, 'Keyboard interrupts do not work in the Guix build container.')
|
|
def test_interrupt_main_subthread(self):
|
|
# Calling start_new_thread with a function that executes interrupt_main
|
|
# should raise KeyboardInterrupt upon completion.
|
|
@@ -1409,6 +1410,8 @@ class InterruptMainTests(unittest.TestCase):
|
|
t.join()
|
|
t.join()
|
|
|
|
+
|
|
+ @unittest.skipIf(True, 'Keyboard interrupts do not work in the Guix build container.')
|
|
def test_interrupt_main_mainthread(self):
|
|
# Make sure that if interrupt_main is called in main thread that
|
|
# KeyboardInterrupt is raised instantly.
|
|
diff --git a/Lib/test/test_unicodedata.py b/Lib/test/test_unicodedata.py
|
|
index b552d2bd17..28b1144e15 100644
|
|
--- a/Lib/test/test_unicodedata.py
|
|
+++ b/Lib/test/test_unicodedata.py
|
|
@@ -309,6 +309,7 @@ class UnicodeMiscTest(UnicodeDatabaseTest):
|
|
self.assertEqual(len(lines), 1,
|
|
r"\u%.4x should not be a linebreak" % i)
|
|
|
|
+@requires_resource('network')
|
|
class NormalizationTest(unittest.TestCase):
|
|
@staticmethod
|
|
def check_version(testfile):
|
|
diff --git a/Tools/scripts/run_tests.py b/Tools/scripts/run_tests.py
|
|
index bcfa5e943b..1f2484971b 100644
|
|
--- a/Tools/scripts/run_tests.py
|
|
+++ b/Tools/scripts/run_tests.py
|
|
@@ -41,7 +41,7 @@ def main(regrtest_args):
|
|
if not any(is_multiprocess_flag(arg) for arg in regrtest_args):
|
|
args.extend(['-j', '0']) # Use all CPU cores
|
|
if not any(is_resource_use_flag(arg) for arg in regrtest_args):
|
|
- args.extend(['-u', 'all,-largefile,-audio,-gui'])
|
|
+ args.extend(['-u', 'all,-largefile,-audio,-gui,-network'])
|
|
args.extend(regrtest_args)
|
|
print(' '.join(args))
|
|
if sys.platform == 'win32':
|
|
--
|
|
2.29.2
|
|
|