mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
afdc16d904
* gnu/packages/patches/x265-arm-flags.patch: Update patch. * gnu/packages/video.scm (x265): Update to 3.4. [arguments]: Remove obsolete substitution. Disable the newly-added assembly optimizations on AArch64, as they are not implemented for all targets we build.
36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
Fix build flags for ARMv7.
|
|
|
|
Taken from Debian:
|
|
https://salsa.debian.org/multimedia-team/x265/-/blob/master/debian/patches/0001-Fix-arm-flags.patch
|
|
|
|
From: Sebastian Ramacher <sramacher@debian.org>
|
|
Date: Wed, 26 Apr 2017 22:05:06 +0200
|
|
Subject: Fix arm* flags
|
|
|
|
---
|
|
source/CMakeLists.txt | 6 +-----
|
|
1 file changed, 1 insertion(+), 5 deletions(-)
|
|
|
|
diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
|
|
--- a/source/CMakeLists.txt
|
|
+++ b/source/CMakeLists.txt
|
|
@@ -77,7 +77,7 @@ elseif(ARMMATCH GREATER "-1")
|
|
add_definitions(-DX265_ARCH_ARM=1 -DX265_ARCH_ARM64=1 -DHAVE_ARMV6=0)
|
|
else()
|
|
message(STATUS "Detected ARM target processor")
|
|
- add_definitions(-DX265_ARCH_ARM=1 -DX265_ARCH_ARM64=0 -DHAVE_ARMV6=1)
|
|
+ add_definitions(-DX265_ARCH_ARM=1)
|
|
endif()
|
|
else()
|
|
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
|
|
@@ -252,10 +252,7 @@ if(GCC)
|
|
else()
|
|
find_package(Neon)
|
|
if(CPU_HAS_NEON)
|
|
- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC)
|
|
add_definitions(-DHAVE_NEON)
|
|
- else()
|
|
- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm)
|
|
endif()
|
|
endif()
|
|
endif()
|