mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-19 13:17:10 -05:00
838427499d
* gnu/packages/xml.scm (python-libxml2)[source]: Add patch. * gnu/packages/patches/python-libxml2-python39-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
94 lines
3 KiB
Diff
94 lines
3 KiB
Diff
https://gitlab.gnome.org/GNOME/libxml2/-/commit/e4fb36841800038c289997432ca547c9bfef9db1.patch
|
|
|
|
From e4fb36841800038c289997432ca547c9bfef9db1 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
|
Date: Fri, 28 Feb 2020 12:48:14 +0100
|
|
Subject: [PATCH] Parenthesize Py<type>_Check() in ifs
|
|
|
|
In C, if expressions should be parenthesized.
|
|
PyLong_Check, PyUnicode_Check etc. happened to expand to a parenthesized
|
|
expression before, but that's not API to rely on.
|
|
|
|
Since Python 3.9.0a4 it needs to be parenthesized explicitly.
|
|
|
|
Fixes https://gitlab.gnome.org/GNOME/libxml2/issues/149
|
|
---
|
|
python/libxml.c | 4 ++--
|
|
python/types.c | 12 ++++++------
|
|
2 files changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/python/libxml.c b/python/libxml.c
|
|
index bc676c4e..81e709f3 100644
|
|
--- a/python/libxml.c
|
|
+++ b/python/libxml.c
|
|
@@ -294,7 +294,7 @@ xmlPythonFileReadRaw (void * context, char * buffer, int len) {
|
|
lenread = PyBytes_Size(ret);
|
|
data = PyBytes_AsString(ret);
|
|
#ifdef PyUnicode_Check
|
|
- } else if PyUnicode_Check (ret) {
|
|
+ } else if (PyUnicode_Check (ret)) {
|
|
#if PY_VERSION_HEX >= 0x03030000
|
|
Py_ssize_t size;
|
|
const char *tmp;
|
|
@@ -359,7 +359,7 @@ xmlPythonFileRead (void * context, char * buffer, int len) {
|
|
lenread = PyBytes_Size(ret);
|
|
data = PyBytes_AsString(ret);
|
|
#ifdef PyUnicode_Check
|
|
- } else if PyUnicode_Check (ret) {
|
|
+ } else if (PyUnicode_Check (ret)) {
|
|
#if PY_VERSION_HEX >= 0x03030000
|
|
Py_ssize_t size;
|
|
const char *tmp;
|
|
diff --git a/python/types.c b/python/types.c
|
|
index c2bafeb1..ed284ec7 100644
|
|
--- a/python/types.c
|
|
+++ b/python/types.c
|
|
@@ -602,16 +602,16 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
|
if (obj == NULL) {
|
|
return (NULL);
|
|
}
|
|
- if PyFloat_Check (obj) {
|
|
+ if (PyFloat_Check (obj)) {
|
|
ret = xmlXPathNewFloat((double) PyFloat_AS_DOUBLE(obj));
|
|
- } else if PyLong_Check(obj) {
|
|
+ } else if (PyLong_Check(obj)) {
|
|
#ifdef PyLong_AS_LONG
|
|
ret = xmlXPathNewFloat((double) PyLong_AS_LONG(obj));
|
|
#else
|
|
ret = xmlXPathNewFloat((double) PyInt_AS_LONG(obj));
|
|
#endif
|
|
#ifdef PyBool_Check
|
|
- } else if PyBool_Check (obj) {
|
|
+ } else if (PyBool_Check (obj)) {
|
|
|
|
if (obj == Py_True) {
|
|
ret = xmlXPathNewBoolean(1);
|
|
@@ -620,14 +620,14 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
|
ret = xmlXPathNewBoolean(0);
|
|
}
|
|
#endif
|
|
- } else if PyBytes_Check (obj) {
|
|
+ } else if (PyBytes_Check (obj)) {
|
|
xmlChar *str;
|
|
|
|
str = xmlStrndup((const xmlChar *) PyBytes_AS_STRING(obj),
|
|
PyBytes_GET_SIZE(obj));
|
|
ret = xmlXPathWrapString(str);
|
|
#ifdef PyUnicode_Check
|
|
- } else if PyUnicode_Check (obj) {
|
|
+ } else if (PyUnicode_Check (obj)) {
|
|
#if PY_VERSION_HEX >= 0x03030000
|
|
xmlChar *str;
|
|
const char *tmp;
|
|
@@ -650,7 +650,7 @@ libxml_xmlXPathObjectPtrConvert(PyObject *obj)
|
|
ret = xmlXPathWrapString(str);
|
|
#endif
|
|
#endif
|
|
- } else if PyList_Check (obj) {
|
|
+ } else if (PyList_Check (obj)) {
|
|
int i;
|
|
PyObject *node;
|
|
xmlNodePtr cur;
|
|
--
|
|
GitLab
|
|
|