guix/gnu/packages/patches/gdbm-gcc-compat.patch
Marius Bakke 420ddd0a91
gnu: gdbm: Fix build with GCC 10.
* gnu/packages/patches/gdbm-gcc-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/dbm.scm (gdbm)[source](patches): New field.
2020-12-17 00:15:48 +01:00

16 lines
512 B
Diff
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Fix build failure with GCC 10 due to duplicate definitions. It can be
reproduced on older compilers with -fno-common.
Fix taken from Gentoo: https://bugs.gentoo.org/705898
--- a/src/parseopt.c
+++ b/src/parseopt.c
@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
}
char *parseopt_program_name;
-char *parseopt_program_doc;
-char *parseopt_program_args;
const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
void (*parseopt_help_hook) (FILE *stream);