mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-25 12:09:15 -05:00
420ddd0a91
* gnu/packages/patches/gdbm-gcc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/dbm.scm (gdbm)[source](patches): New field.
16 lines
512 B
Diff
16 lines
512 B
Diff
Fix build failure with GCC 10 due to duplicate definitions. It can be
|
||
reproduced on older compilers with -fno-common.
|
||
|
||
Fix taken from Gentoo: https://bugs.gentoo.org/705898
|
||
|
||
--- a/src/parseopt.c
|
||
+++ b/src/parseopt.c
|
||
@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
|
||
}
|
||
|
||
char *parseopt_program_name;
|
||
-char *parseopt_program_doc;
|
||
-char *parseopt_program_args;
|
||
const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
|
||
void (*parseopt_help_hook) (FILE *stream);
|
||
|