mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
51f887f33d
python-axolotl has been failing since March, https://hydra.gnu.org/job/gnu/master/python-axolotl-0.1.35.x86_64-linux This also fixes the OMEMO and OTR plugins for Gajim work. * gnu/packages/patches/python-axolotl-AES-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-crypto.scm (python-axolotl): Upgrade to 0.1.39. [source]: Use the patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
24 lines
844 B
Diff
24 lines
844 B
Diff
Patch taken from the Debian package for python-axolotl-0.1.39.
|
|
See <https://bugs.gnu.org/29415>.
|
|
|
|
Description: Removes IV paramenter from AES constructor, since it is not necessary for ctr mode.
|
|
Author: Josue Ortega <josue@debian.org>
|
|
Last-Update: 2017-04-13
|
|
|
|
--- a/axolotl/sessioncipher.py
|
|
+++ b/axolotl/sessioncipher.py
|
|
@@ -228,13 +228,7 @@
|
|
# counterint = struct.unpack(">L", counterbytes)[0]
|
|
# counterint = int.from_bytes(counterbytes, byteorder='big')
|
|
ctr = Counter.new(128, initial_value=counter)
|
|
-
|
|
- # cipher = AES.new(key, AES.MODE_CTR, counter=ctr)
|
|
- ivBytes = bytearray(16)
|
|
- ByteUtil.intToByteArray(ivBytes, 0, counter)
|
|
-
|
|
- cipher = AES.new(key, AES.MODE_CTR, IV=bytes(ivBytes), counter=ctr)
|
|
-
|
|
+ cipher = AES.new(key, AES.MODE_CTR, counter=ctr)
|
|
return cipher
|
|
|
|
|