mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-07 11:54:33 -05:00
2a666e9cfd
* gnu/packages/patches/icecat-CVE-2014-8634-pt1.patch, gnu/packages/patches/icecat-CVE-2014-8634-pt2.patch, gnu/packages/patches/icecat-CVE-2014-8638-pt1.patch, gnu/packages/patches/icecat-CVE-2014-8638-pt2.patch, gnu/packages/patches/icecat-CVE-2014-8639.patch, gnu/packages/patches/icecat-CVE-2014-8641.patch, gnu/packages/patches/icecat-armhf-xpcom.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
30 lines
1 KiB
Diff
30 lines
1 KiB
Diff
From e5de31c8f927b1aa06dde02c356cda33beb463d9 Mon Sep 17 00:00:00 2001
|
|
From: Kyle Huey <khuey@kylehuey.com>
|
|
Date: Fri, 19 Dec 2014 18:16:17 -0800
|
|
Subject: [PATCH] Bug 1111737. r=smaug, a=bkerensa
|
|
|
|
---
|
|
content/base/src/nsScriptLoader.cpp | 7 ++++++-
|
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/content/base/src/nsScriptLoader.cpp b/content/base/src/nsScriptLoader.cpp
|
|
index a6a4c34..7f3a76e 100644
|
|
--- a/content/base/src/nsScriptLoader.cpp
|
|
+++ b/content/base/src/nsScriptLoader.cpp
|
|
@@ -812,7 +812,12 @@ NotifyOffThreadScriptLoadCompletedRunnable::Run()
|
|
{
|
|
MOZ_ASSERT(NS_IsMainThread());
|
|
|
|
- nsresult rv = mLoader->ProcessOffThreadRequest(mRequest, &mToken);
|
|
+ // We want these to be dropped on the main thread, once we return from this
|
|
+ // function.
|
|
+ nsRefPtr<nsScriptLoadRequest> request = mRequest.forget();
|
|
+ nsRefPtr<nsScriptLoader> loader = mLoader.forget();
|
|
+
|
|
+ nsresult rv = loader->ProcessOffThreadRequest(request, &mToken);
|
|
|
|
if (mToken) {
|
|
// The result of the off thread parse was not actually needed to process
|
|
--
|
|
2.1.2
|
|
|