mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
35afdc3b5c
* gnu/packages/machine-learning.scm (xgboost, python-xgboost): Update to 1.7.6. (python-xgboost)[arguments]: Remove #:test-flags and disable tests. * gnu/packages/patches/xgboost-use-system-dmlc-core.patch: Update patch. Change-Id: Ib0eb015f72150ef82ce386eda26749e25f816e95
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
# This patch was imported from Debian: https://sources.debian.org/patches/xgboost/1.7.4-1/cmake-dmlc-core.patch/
|
|
|
|
Index: xgboost/CMakeLists.txt
|
|
===================================================================
|
|
--- xgboost.orig/CMakeLists.txt
|
|
+++ xgboost/CMakeLists.txt
|
|
@@ -205,7 +205,9 @@ msvc_use_static_runtime()
|
|
if (FORCE_SHARED_CRT)
|
|
set(DMLC_FORCE_SHARED_CRT ON)
|
|
endif ()
|
|
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
|
|
+add_library(dmlc SHARED IMPORTED)
|
|
+find_library(DMLC_LIBRARY dmlc)
|
|
+set_property(TARGET dmlc PROPERTY IMPORTED_LOCATION "${DMLC_LIBRARY}")
|
|
|
|
if (MSVC)
|
|
if (TARGET dmlc_unit_tests)
|
|
@@ -267,7 +269,7 @@ set_target_properties(runxgboost PROPERT
|
|
#-- End CLI for xgboost
|
|
|
|
# Common setup for all targets
|
|
-foreach(target xgboost objxgboost dmlc runxgboost)
|
|
+foreach(target xgboost objxgboost runxgboost)
|
|
xgboost_target_properties(${target})
|
|
xgboost_target_link_libraries(${target})
|
|
xgboost_target_defs(${target})
|
|
@@ -318,7 +320,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/
|
|
#
|
|
# https://github.com/dmlc/xgboost/issues/6085
|
|
if (BUILD_STATIC_LIB)
|
|
- set(INSTALL_TARGETS xgboost runxgboost objxgboost dmlc)
|
|
+ set(INSTALL_TARGETS xgboost runxgboost objxgboost)
|
|
else (BUILD_STATIC_LIB)
|
|
set(INSTALL_TARGETS xgboost runxgboost)
|
|
endif (BUILD_STATIC_LIB)
|