mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
e9f5dfc004
* gnu/packages/mail.scm (mutt): Update to 2.0.2. * gnu/packages/patches/mutt-store-references.patch: Adjust to changes in Mutt 2.0.2.
17 lines
478 B
Diff
17 lines
478 B
Diff
By default 'mutt' embeds configure flags and the output of 'gcc -v',
|
|
which contains the store file name of Bash and GCC. This patch makes
|
|
sure we don't embed a reference to these in 'mutt'.
|
|
|
|
diff --git a/txt2c.sh b/txt2c.sh
|
|
index f634bb9..53845cf 100755
|
|
--- a/txt2c.sh
|
|
+++ b/txt2c.sh
|
|
@@ -21,6 +21,8 @@ txt2c_fallback () {
|
|
echo ";"
|
|
}
|
|
|
|
+echo "unsigned char $1[] = \"value of '$1' not kept\";"
|
|
+exit 0
|
|
if ./txt2c test </dev/null >/dev/null 2>&1; then
|
|
./txt2c "$1"
|
|
else
|