mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
be3908fa14
* gnu/packages/patches/qemu-CVE-2020-8608.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/virtualization.scm (qemu)[source]: Use it.
269 lines
10 KiB
Diff
269 lines
10 KiB
Diff
Fix CVE-2020-8608:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8608
|
|
https://www.openwall.com/lists/oss-security/2020/02/06/2
|
|
|
|
Patches copied from upstream dependency repository:
|
|
|
|
https://gitlab.freedesktop.org/slirp/libslirp/commit/68ccb8021a838066f0951d4b2817eb6b6f10a843
|
|
https://gitlab.freedesktop.org/slirp/libslirp/commit/30648c03b27fb8d9611b723184216cd3174b6775
|
|
|
|
From 68ccb8021a838066f0951d4b2817eb6b6f10a843 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
|
Date: Mon, 27 Jan 2020 10:24:14 +0100
|
|
Subject: [PATCH] tcp_emu: fix unsafe snprintf() usages
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Various calls to snprintf() assume that snprintf() returns "only" the
|
|
number of bytes written (excluding terminating NUL).
|
|
|
|
https://pubs.opengroup.org/onlinepubs/9699919799/functions/snprintf.html#tag_16_159_04
|
|
|
|
"Upon successful completion, the snprintf() function shall return the
|
|
number of bytes that would be written to s had n been sufficiently
|
|
large excluding the terminating null byte."
|
|
|
|
Before patch ce131029, if there isn't enough room in "m_data" for the
|
|
"DCC ..." message, we overflow "m_data".
|
|
|
|
After the patch, if there isn't enough room for the same, we don't
|
|
overflow "m_data", but we set "m_len" out-of-bounds. The next time an
|
|
access is bounded by "m_len", we'll have a buffer overflow then.
|
|
|
|
Use slirp_fmt*() to fix potential OOB memory access.
|
|
|
|
Reported-by: Laszlo Ersek <lersek@redhat.com>
|
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
Reviewed-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
|
Message-Id: <20200127092414.169796-7-marcandre.lureau@redhat.com>
|
|
---
|
|
src/tcp_subr.c | 44 +++++++++++++++++++++-----------------------
|
|
1 file changed, 21 insertions(+), 23 deletions(-)
|
|
|
|
diff --git a/src/tcp_subr.c b/src/tcp_subr.c
|
|
index a699117..a72c86b 100644
|
|
--- a/slirp/src/tcp_subr.c
|
|
+++ b/slirp/src/tcp_subr.c
|
|
@@ -643,8 +643,7 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
NTOHS(n1);
|
|
NTOHS(n2);
|
|
m_inc(m, snprintf(NULL, 0, "%d,%d\r\n", n1, n2) + 1);
|
|
- m->m_len = snprintf(m->m_data, M_ROOM(m), "%d,%d\r\n", n1, n2);
|
|
- assert(m->m_len < M_ROOM(m));
|
|
+ m->m_len = slirp_fmt(m->m_data, M_ROOM(m), "%d,%d\r\n", n1, n2);
|
|
} else {
|
|
*eol = '\r';
|
|
}
|
|
@@ -684,9 +683,9 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
n4 = (laddr & 0xff);
|
|
|
|
m->m_len = bptr - m->m_data; /* Adjust length */
|
|
- m->m_len += snprintf(bptr, M_FREEROOM(m),
|
|
- "ORT %d,%d,%d,%d,%d,%d\r\n%s", n1, n2, n3, n4,
|
|
- n5, n6, x == 7 ? buff : "");
|
|
+ m->m_len += slirp_fmt(bptr, M_FREEROOM(m),
|
|
+ "ORT %d,%d,%d,%d,%d,%d\r\n%s",
|
|
+ n1, n2, n3, n4, n5, n6, x == 7 ? buff : "");
|
|
return 1;
|
|
} else if ((bptr = (char *)strstr(m->m_data, "27 Entering")) != NULL) {
|
|
/*
|
|
@@ -719,10 +718,9 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
n4 = (laddr & 0xff);
|
|
|
|
m->m_len = bptr - m->m_data; /* Adjust length */
|
|
- m->m_len += snprintf(bptr, M_FREEROOM(m),
|
|
- "27 Entering Passive Mode (%d,%d,%d,%d,%d,%d)\r\n%s",
|
|
- n1, n2, n3, n4, n5, n6, x == 7 ? buff : "");
|
|
-
|
|
+ m->m_len += slirp_fmt(bptr, M_FREEROOM(m),
|
|
+ "27 Entering Passive Mode (%d,%d,%d,%d,%d,%d)\r\n%s",
|
|
+ n1, n2, n3, n4, n5, n6, x == 7 ? buff : "");
|
|
return 1;
|
|
}
|
|
|
|
@@ -745,8 +743,8 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
if (m->m_data[m->m_len - 1] == '\0' && lport != 0 &&
|
|
(so = tcp_listen(slirp, INADDR_ANY, 0, so->so_laddr.s_addr,
|
|
htons(lport), SS_FACCEPTONCE)) != NULL)
|
|
- m->m_len = snprintf(m->m_data, M_ROOM(m),
|
|
- "%d", ntohs(so->so_fport)) + 1;
|
|
+ m->m_len = slirp_fmt0(m->m_data, M_ROOM(m),
|
|
+ "%d", ntohs(so->so_fport));
|
|
return 1;
|
|
|
|
case EMU_IRC:
|
|
@@ -765,10 +763,10 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
return 1;
|
|
}
|
|
m->m_len = bptr - m->m_data; /* Adjust length */
|
|
- m->m_len += snprintf(bptr, M_FREEROOM(m),
|
|
- "DCC CHAT chat %lu %u%c\n",
|
|
- (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
- ntohs(so->so_fport), 1);
|
|
+ m->m_len += slirp_fmt(bptr, M_FREEROOM(m),
|
|
+ "DCC CHAT chat %lu %u%c\n",
|
|
+ (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
+ ntohs(so->so_fport), 1);
|
|
} else if (sscanf(bptr, "DCC SEND %256s %u %u %u", buff, &laddr, &lport,
|
|
&n1) == 4) {
|
|
if ((so = tcp_listen(slirp, INADDR_ANY, 0, htonl(laddr),
|
|
@@ -776,10 +774,10 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
return 1;
|
|
}
|
|
m->m_len = bptr - m->m_data; /* Adjust length */
|
|
- m->m_len += snprintf(bptr, M_FREEROOM(m),
|
|
- "DCC SEND %s %lu %u %u%c\n", buff,
|
|
- (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
- ntohs(so->so_fport), n1, 1);
|
|
+ m->m_len += slirp_fmt(bptr, M_FREEROOM(m),
|
|
+ "DCC SEND %s %lu %u %u%c\n", buff,
|
|
+ (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
+ ntohs(so->so_fport), n1, 1);
|
|
} else if (sscanf(bptr, "DCC MOVE %256s %u %u %u", buff, &laddr, &lport,
|
|
&n1) == 4) {
|
|
if ((so = tcp_listen(slirp, INADDR_ANY, 0, htonl(laddr),
|
|
@@ -787,10 +785,10 @@ int tcp_emu(struct socket *so, struct mbuf *m)
|
|
return 1;
|
|
}
|
|
m->m_len = bptr - m->m_data; /* Adjust length */
|
|
- m->m_len += snprintf(bptr, M_FREEROOM(m),
|
|
- "DCC MOVE %s %lu %u %u%c\n", buff,
|
|
- (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
- ntohs(so->so_fport), n1, 1);
|
|
+ m->m_len += slirp_fmt(bptr, M_FREEROOM(m),
|
|
+ "DCC MOVE %s %lu %u %u%c\n", buff,
|
|
+ (unsigned long)ntohl(so->so_faddr.s_addr),
|
|
+ ntohs(so->so_fport), n1, 1);
|
|
}
|
|
return 1;
|
|
|
|
--
|
|
2.25.1
|
|
|
|
From 30648c03b27fb8d9611b723184216cd3174b6775 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
|
Date: Mon, 27 Jan 2020 10:24:09 +0100
|
|
Subject: [PATCH] util: add slirp_fmt() helpers
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Various calls to snprintf() in libslirp assume that snprintf() returns
|
|
"only" the number of bytes written (excluding terminating NUL).
|
|
|
|
https://pubs.opengroup.org/onlinepubs/9699919799/functions/snprintf.html#tag_16_159_04
|
|
|
|
"Upon successful completion, the snprintf() function shall return the
|
|
number of bytes that would be written to s had n been sufficiently
|
|
large excluding the terminating null byte."
|
|
|
|
Introduce slirp_fmt() that handles several pathological cases the
|
|
way libslirp usually expect:
|
|
|
|
- treat error as fatal (instead of silently returning -1)
|
|
|
|
- fmt0() will always \0 end
|
|
|
|
- return the number of bytes actually written (instead of what would
|
|
have been written, which would usually result in OOB later), including
|
|
the ending \0 for fmt0()
|
|
|
|
- warn if truncation happened (instead of ignoring)
|
|
|
|
Other less common cases can still be handled with strcpy/snprintf() etc.
|
|
|
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
Reviewed-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
|
Message-Id: <20200127092414.169796-2-marcandre.lureau@redhat.com>
|
|
---
|
|
src/util.c | 62 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
|
src/util.h | 3 +++
|
|
2 files changed, 65 insertions(+)
|
|
|
|
diff --git a/src/util.c b/src/util.c
|
|
index e596087..e3b6257 100644
|
|
--- a/slirp/src/util.c
|
|
+++ b/slirp/src/util.c
|
|
@@ -364,3 +364,65 @@ void slirp_pstrcpy(char *buf, int buf_size, const char *str)
|
|
}
|
|
*q = '\0';
|
|
}
|
|
+
|
|
+static int slirp_vsnprintf(char *str, size_t size,
|
|
+ const char *format, va_list args)
|
|
+{
|
|
+ int rv = vsnprintf(str, size, format, args);
|
|
+
|
|
+ if (rv < 0) {
|
|
+ g_error("vsnprintf() failed: %s", g_strerror(errno));
|
|
+ }
|
|
+
|
|
+ return rv;
|
|
+}
|
|
+
|
|
+/*
|
|
+ * A snprintf()-like function that:
|
|
+ * - returns the number of bytes written (excluding optional \0-ending)
|
|
+ * - dies on error
|
|
+ * - warn on truncation
|
|
+ */
|
|
+int slirp_fmt(char *str, size_t size, const char *format, ...)
|
|
+{
|
|
+ va_list args;
|
|
+ int rv;
|
|
+
|
|
+ va_start(args, format);
|
|
+ rv = slirp_vsnprintf(str, size, format, args);
|
|
+ va_end(args);
|
|
+
|
|
+ if (rv > size) {
|
|
+ g_critical("vsnprintf() truncation");
|
|
+ }
|
|
+
|
|
+ return MIN(rv, size);
|
|
+}
|
|
+
|
|
+/*
|
|
+ * A snprintf()-like function that:
|
|
+ * - always \0-end (unless size == 0)
|
|
+ * - returns the number of bytes actually written, including \0 ending
|
|
+ * - dies on error
|
|
+ * - warn on truncation
|
|
+ */
|
|
+int slirp_fmt0(char *str, size_t size, const char *format, ...)
|
|
+{
|
|
+ va_list args;
|
|
+ int rv;
|
|
+
|
|
+ va_start(args, format);
|
|
+ rv = slirp_vsnprintf(str, size, format, args);
|
|
+ va_end(args);
|
|
+
|
|
+ if (rv >= size) {
|
|
+ g_critical("vsnprintf() truncation");
|
|
+ if (size > 0)
|
|
+ str[size - 1] = '\0';
|
|
+ rv = size;
|
|
+ } else {
|
|
+ rv += 1; /* include \0 */
|
|
+ }
|
|
+
|
|
+ return rv;
|
|
+}
|
|
diff --git a/src/util.h b/src/util.h
|
|
index e9c3073..5530c46 100644
|
|
--- a/slirp/src/util.h
|
|
+++ b/slirp/src/util.h
|
|
@@ -181,4 +181,7 @@ static inline int slirp_socket_set_fast_reuse(int fd)
|
|
|
|
void slirp_pstrcpy(char *buf, int buf_size, const char *str);
|
|
|
|
+int slirp_fmt(char *str, size_t size, const char *format, ...);
|
|
+int slirp_fmt0(char *str, size_t size, const char *format, ...);
|
|
+
|
|
#endif
|
|
--
|
|
2.25.1
|
|
|