mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
8515ea12d2
At least 'audiofile-division-by-zero-BlockCodec-runPull.patch' could end up not being included in a tarball. * gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch: Rename to... * gnu/packages/patches/audiofile-check-number-of-coefficients.patch: ... this. * gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch: Rename to... * gnu/packages/patches/audiofile-division-by-zero.patch: ....this. * gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: Rename to... * gnu/packages/patches/audiofile-function-signature.patch: ... this. * gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch: Rename to.... * gnu/packages/patches/audiofile-multiply-overflow.patch: ... this. * gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch: Rename to... * gnu/packages/patches/audiofile-overflow-in-MSADPCM.patch: ... this. * gnu/packages/audio.scm (audiofile)[source]: Adjust accordingly. * gnu/local.mk (dist_patch_DATA): Likewise.
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From: Antonio Larrosa <larrosa@kde.org>
|
|
Date: Fri, 10 Mar 2017 15:40:02 +0100
|
|
Subject: Fix signature of multiplyCheckOverflow. It returns a bool, not an int
|
|
|
|
---
|
|
libaudiofile/modules/MSADPCM.cpp | 2 +-
|
|
sfcommands/sfconvert.c | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libaudiofile/modules/MSADPCM.cpp b/libaudiofile/modules/MSADPCM.cpp
|
|
index ef9c38c..d8c9553 100644
|
|
--- a/libaudiofile/modules/MSADPCM.cpp
|
|
+++ b/libaudiofile/modules/MSADPCM.cpp
|
|
@@ -116,7 +116,7 @@ int firstBitSet(int x)
|
|
#define __has_builtin(x) 0
|
|
#endif
|
|
|
|
-int multiplyCheckOverflow(int a, int b, int *result)
|
|
+bool multiplyCheckOverflow(int a, int b, int *result)
|
|
{
|
|
#if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
|
|
return __builtin_mul_overflow(a, b, result);
|
|
diff --git a/sfcommands/sfconvert.c b/sfcommands/sfconvert.c
|
|
index 970a3e4..367f7a5 100644
|
|
--- a/sfcommands/sfconvert.c
|
|
+++ b/sfcommands/sfconvert.c
|
|
@@ -60,7 +60,7 @@ int firstBitSet(int x)
|
|
#define __has_builtin(x) 0
|
|
#endif
|
|
|
|
-int multiplyCheckOverflow(int a, int b, int *result)
|
|
+bool multiplyCheckOverflow(int a, int b, int *result)
|
|
{
|
|
#if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
|
|
return __builtin_mul_overflow(a, b, result);
|