mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
a10cce5246
* gnu/packages/web.scm (netsurf): Update to 3.11. [arguments]: Adjust to new source. Netsurf's JS engine cannot handle DuckDuckGo's redirect urls, so replace websearch form with post to DuckDuckGo Lite. (netsurf-buildsystem): Update to 1.10 (libparserutils): Update to 0.2.5. (hubbub): Update to 0.3.8. [source]: Remove hubbub-maybe-uninitialized.patch. (libcss): Update to 0.9.2. [source]: Remove snippet. Add patch for tests. (libdom): Update to 0.4.2. (libsvgtiny): Update to 0.1.8. (libnsbmp): Update to 0.1.7. (libnsgif): Update to 1.0.0. (libnsutils): Update to 0.1.1. (libnspsl): Update to 0.1.7. (nsgenbind): Update to 0.9. * gnu/packages/patches/netsurf-message-timestamp.patch: Adjust to latest source. * gnu/packages/patches/hubbub-maybe-uninitialized.patch: Delete patch. * gnu/packages/patches/libcss-check-format.patch: New patch. * gnu/local.mk (dist_patch_DATA): Adjust. Change-Id: I5834b0418270309aa30b6cd0a5a307e20c00fd4a
11 lines
330 B
Diff
11 lines
330 B
Diff
--- netsurf-3.11/tools/split-messages.pl.orig
|
|
+++ netsurf-3.11/tools/split-messages.pl
|
|
@@ -238,7 +238,7 @@
|
|
|
|
if( $opt{gzip} )
|
|
{
|
|
- $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9 );
|
|
+ $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9, Time => 0 );
|
|
}
|
|
|
|
return $ofh;
|