mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
007c75f56f
* gnu/packages/patches/ao-cad-aarch64-support.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (ao-cad)[source]: Use it. Update snapshot to fb288c9. Use VCS helpers for version and file-name. [arguments]: Add 'remove-native-compilation' phase.
18 lines
629 B
Diff
18 lines
629 B
Diff
Support in ao-cad for aarch64.
|
|
|
|
Submitted upstream at https://github.com/mkeeter/ao/issues/69
|
|
|
|
--- ao/ui/vendor/efsw/src/efsw/inotify-nosys.h.orig 2017-12-14 16:27:16.125871099 -0600
|
|
+++ ao/ui/vendor/efsw/src/efsw/inotify-nosys.h 2017-12-14 16:26:39.786022981 -0600
|
|
@@ -69,6 +69,11 @@
|
|
# define __NR_inotify_add_watch (__NR_SYSCALL_BASE+317)
|
|
# define __NR_inotify_rm_watch (__NR_SYSCALL_BASE+318)
|
|
|
|
+#elif defined (__aarch64__)
|
|
+# define __NR_inotify_init 1043
|
|
+# define __NR_inotify_add_watch 27
|
|
+# define __NR_inotify_rm_watch 28
|
|
+
|
|
#elif defined (__frv__)
|
|
# define __NR_inotify_init 291
|
|
# define __NR_inotify_add_watch 292
|