mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
19d2713196
Fixes bug #24069. perl is made a native input to all of the gcc-* packages except for gcc-boot0; perl-boot0 is made a native input to gcc-final. * gnu/packages/patches/gcc-fix-texi2pod.patch: Add patch file to fix texi2pod. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gcc.scm (gcc-4.7, gcc-4.8, gcc-4.9, gcc-5): Use it. (gcc-4.7)[native-inputs]: Add perl. (gcc-4.9)[native-inputs]: Likewise. * gnu/packages/commencement.scm (gcc-boot0)[native-inputs]: Remove perl. (gcc-final)[native-inputs]: Add perl-boot0. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
19 lines
907 B
Diff
19 lines
907 B
Diff
This patch was taken from the official GCC git repository.
|
|
X-Git-Url: https://gcc.gnu.org/git/?p=gcc.git;a=blobdiff_plain;f=contrib%2Ftexi2pod.pl;h=91bdbb5cea933d0381f2924ab94490fca31d5800;hp=eba1bcaa3cffa78b46030b219d04fe7d68367658;hb=67b56c905078d49d3e4028085e5cb1e1fb87a8aa;hpb=2f508a78310caab123e9794d3dcfe41f2769449b
|
|
|
|
It fixes a defect in the contrib/texi2pod.pl script that prevented generating
|
|
manual pages. It was corrected in the GCC 6.X series.
|
|
|
|
diff --git a/contrib/texi2pod.pl b/contrib/texi2pod.pl
|
|
index eba1bca..91bdbb5 100755
|
|
--- a/contrib/texi2pod.pl
|
|
+++ b/contrib/texi2pod.pl
|
|
@@ -316,7 +316,7 @@ while(<$inf>) {
|
|
@columns = ();
|
|
for $column (split (/\s*\@tab\s*/, $1)) {
|
|
# @strong{...} is used a @headitem work-alike
|
|
- $column =~ s/^\@strong{(.*)}$/$1/;
|
|
+ $column =~ s/^\@strong\{(.*)\}$/$1/;
|
|
push @columns, $column;
|
|
}
|
|
$_ = "\n=item ".join (" : ", @columns)."\n";
|