mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
17aa4eb4e1
* gnu/packages/audio.scm (ableton-link): New variable. * gnu/packages/patches/ableton-link-system-libraries-debian.patch: Patch CMakeLists.txt to use system libraries. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
This patch was borrowed from Debian's package:
|
|
https://salsa.debian.org/multimedia-team/ableton-link/-/blob/9c65141bf5bba0872811c179af77ac95770352cc/debian/patches/DEBIAN_system_libraries.patch
|
|
Description: Drop dependencies on included 3rd-party libs
|
|
upstream includes git-submodules for Catch and ASIO (not found in the tarball).
|
|
on Debian we want to use the system provided libraries.
|
|
Author: IOhannes m zmölnig
|
|
Origin: Debian
|
|
Forwarded: not-needed
|
|
Last-Update: 2016-10-26
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
--- ableton-link.orig/cmake_include/AsioStandaloneConfig.cmake
|
|
+++ ableton-link/cmake_include/AsioStandaloneConfig.cmake
|
|
@@ -1,6 +1,2 @@
|
|
add_library(AsioStandalone::AsioStandalone IMPORTED INTERFACE)
|
|
|
|
-set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
|
|
- INTERFACE_INCLUDE_DIRECTORIES
|
|
- ${CMAKE_CURRENT_LIST_DIR}/../modules/asio-standalone/asio/include
|
|
-)
|
|
--- ableton-link.orig/cmake_include/CatchConfig.cmake
|
|
+++ ableton-link/cmake_include/CatchConfig.cmake
|
|
@@ -1,6 +1,2 @@
|
|
add_library(Catch::Catch IMPORTED INTERFACE)
|
|
|
|
-set_property(TARGET Catch::Catch APPEND PROPERTY
|
|
- INTERFACE_INCLUDE_DIRECTORIES
|
|
- ${CMAKE_SOURCE_DIR}/third_party/catch
|
|
-)
|