mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
1273548f4f
* gnu/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/backup.scm (restic): Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
51 lines
1.4 KiB
Diff
51 lines
1.4 KiB
Diff
This cherry-picked patch fixes tests for Go >= 1.15. Restic v0.10 (which
|
|
includes this patch) requires go module support from the Go build system.
|
|
Original patch follows.
|
|
|
|
---
|
|
From 97950ab81a18de06b95384da6d8646fef87c9d97 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Neumann <alexander@bumpern.de>
|
|
Date: Sat, 12 Sep 2020 17:36:44 +0200
|
|
Subject: [PATCH] options: Fix test for Go >= 1.15
|
|
|
|
---
|
|
internal/options/options_test.go | 12 +++++++++---
|
|
1 file changed, 9 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/internal/options/options_test.go b/internal/options/options_test.go
|
|
index de94fc90a1..8d268992a3 100644
|
|
--- a/internal/options/options_test.go
|
|
+++ b/internal/options/options_test.go
|
|
@@ -3,6 +3,7 @@ package options
|
|
import (
|
|
"fmt"
|
|
"reflect"
|
|
+ "regexp"
|
|
"testing"
|
|
"time"
|
|
)
|
|
@@ -199,7 +200,7 @@ var invalidSetTests = []struct {
|
|
"timeout": "2134",
|
|
},
|
|
"ns",
|
|
- `time: missing unit in duration 2134`,
|
|
+ `time: missing unit in duration "?2134"?`,
|
|
},
|
|
}
|
|
|
|
@@ -212,8 +213,13 @@ func TestOptionsApplyInvalid(t *testing.T) {
|
|
t.Fatalf("expected error %v not found", test.err)
|
|
}
|
|
|
|
- if err.Error() != test.err {
|
|
- t.Fatalf("expected error %q, got %q", test.err, err.Error())
|
|
+ matched, err := regexp.MatchString(test.err, err.Error())
|
|
+ if err != nil {
|
|
+ t.Fatal(err)
|
|
+ }
|
|
+
|
|
+ if !matched {
|
|
+ t.Fatalf("expected error to match %q, got %q", test.err, err.Error())
|
|
}
|
|
})
|
|
}
|