mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
67c30ff8ad
All packages updated at the same time as they have a shared version. rocclr is no longer a stand-alone package, so the previous version is kept as rocclr-4 and the current version is just the source, rocclr-src, needed by rocm-opencl-runtime. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Update patches. * gnu/packages/rocm.scm (rocm-cmake, rocm-device-libs, rocm-comgr, roct-thunk-interface, rocr-runtime, rocm-opencl-runtime, rocminfo, rocm-bandwidth-test): Update to 5.1.3. (roct-thunk-interface)[inputs]: Add libdrm. [native-inputs]: Add gcc:lib and pkg-config. (rocclr-src): New variable. (rocclr-4): New variable (previous version of the package). (rocm-opencl-runtime)[source]: Remove obsolete patches. [arguments]: Rewrite with gexps. Add needed #:configure-flags. [inputs]: Remove rocclr, add numactl. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
53 lines
1.3 KiB
Diff
53 lines
1.3 KiB
Diff
https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/pull/25
|
|
|
|
From c65cba2e73f9118e128b9ab7e655ee0f8a7798e7 Mon Sep 17 00:00:00 2001
|
|
From: Craig Andrews <candrews@integralblue.com>
|
|
Date: Sun, 1 Mar 2020 19:24:22 -0500
|
|
Subject: [PATCH] Link additional required LLVM libraries
|
|
|
|
Without these additional required dependencies, linking fails with errors such as:
|
|
`undefined reference to llvm::errs()'`
|
|
---
|
|
CMakeLists.txt | 20 ++++++++++++++++++--
|
|
1 file changed, 18 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lib/comgr/CMakeLists.txt b/lib/comgr/CMakeLists.txt
|
|
index 8b5ca2f..a7d226f 100644
|
|
--- a/lib/comgr/CMakeLists.txt
|
|
+++ b/lib/comgr/CMakeLists.txt
|
|
@@ -294,7 +294,11 @@ install(FILES
|
|
DESTINATION "${AMD_COMGR_PACKAGE_PREFIX}")
|
|
|
|
set(CLANG_LIBS
|
|
- clangFrontendTool)
|
|
+ clangFrontendTool
|
|
+ clangFrontend
|
|
+ clangBasic
|
|
+ clangDriver
|
|
+ clangSerialization)
|
|
|
|
set(LLD_LIBS
|
|
lldELF
|
|
@@ -305,8 +309,21 @@ if (LLVM_LINK_LLVM_DYLIB)
|
|
else()
|
|
llvm_map_components_to_libnames(LLVM_LIBS
|
|
${LLVM_TARGETS_TO_BUILD}
|
|
+ Option
|
|
DebugInfoDWARF
|
|
- Symbolize)
|
|
+ Symbolize
|
|
+ Support
|
|
+ Object
|
|
+ BitWriter
|
|
+ MC
|
|
+ MCParser
|
|
+ MCDisassembler
|
|
+ Core
|
|
+ IRReader
|
|
+ CodeGen
|
|
+ Linker
|
|
+ Demangle
|
|
+ BinaryFormat)
|
|
endif()
|
|
|
|
target_link_options(amd_comgr
|