guix/gnu/packages/patches/metabat-fix-boost-issue.patch
Ben Woodcroft d3dce32216
gnu: metabat: Fix boost-related compilation issue.
Reported by Leo Famulari.

* gnu/packages/patches/metabat-fix-boost-issue.patch: New file.
* gnu/packages/bioinformatics.scm (metabat): Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
2017-07-23 22:35:52 +10:00

27 lines
977 B
Diff

This patch fixes the issue described at
https://bitbucket.org/berkeleylab/metabat/issues/28/compilation-fail-with-boost-164
diff --git a/src/metabat.h b/src/metabat.h
index 32ae94c..2292c04 100644
--- a/src/metabat.h
+++ b/src/metabat.h
@@ -35,6 +35,7 @@ KSEQ_INIT(gzFile, gzread)
#include <boost/program_options.hpp>
#include <boost/algorithm/string.hpp>
+#include <boost/serialization/array_wrapper.hpp>
#include <boost/numeric/ublas/matrix.hpp>
#include <boost/math/distributions.hpp>
#include <boost/serialization/serialization.hpp>
diff --git a/src/metabat2.h b/src/metabat2.h
index 60a9998..19fa815 100644
--- a/src/metabat2.h
+++ b/src/metabat2.h
@@ -41,6 +41,7 @@ KSEQ_INIT(gzFile, gzread)
#include <boost/program_options.hpp>
#include <boost/algorithm/string.hpp>
+#include <boost/serialization/array_wrapper.hpp>
#include <boost/numeric/ublas/matrix.hpp>
#include <boost/numeric/ublas/matrix_sparse.hpp>
#include <boost/numeric/ublas/matrix_proxy.hpp>