mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
1717c8a233
Fixes <https://issues.guix.gnu.org/64605> and similar reports. * gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch: New patch. * gnu/packages/patches/qtdeclarative-disable-qmlcache.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/qt.scm (qtdeclarative-5, qtdeclarative): Apply them. Reported-by: Distopico Vegan <distopico@riseup.net>
16 lines
674 B
Diff
16 lines
674 B
Diff
Retrieved from
|
|
https://github.com/NixOS/nixpkgs/raw/master/pkgs/development/libraries/qt-5/5.15/qtdeclarative-default-disable-qmlcache.patch
|
|
|
|
diff --git a/src/qml/qml/qqmltypeloader.cpp b/src/qml/qml/qqmltypeloader.cpp
|
|
index 1d66e75..827567a 100644
|
|
--- a/src/qml/qml/qqmltypeloader.cpp
|
|
+++ b/src/qml/qml/qqmltypeloader.cpp
|
|
@@ -727,7 +727,7 @@ bool QQmlTypeLoader::Blob::isDebugging() const
|
|
|
|
bool QQmlTypeLoader::Blob::diskCacheEnabled() const
|
|
{
|
|
- return (!disableDiskCache() && !isDebugging()) || forceDiskCache();
|
|
+ return forceDiskCache();
|
|
}
|
|
|
|
bool QQmlTypeLoader::Blob::qmldirDataAvailable(const QQmlRefPointer<QQmlQmldirData> &data, QList<QQmlError> *errors)
|