mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
c67f603d55
* gnu/packages/patches/xf86-video-sis-xorg-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/xorg.scm (xf86-video-sis)[source](patches): Use it.
18 lines
702 B
Diff
18 lines
702 B
Diff
Remove use of interface no longer provided by xorg-server.
|
|
|
|
Patch taken from upstream:
|
|
https://cgit.freedesktop.org/xorg/driver/xf86-video-sis/commit/?id=4b1356a2b7fd06e9a05d134caa4033681c939737
|
|
|
|
diff --git a/src/sis_driver.c b/src/sis_driver.c
|
|
index 8f06164..513f68b 100644
|
|
--- a/src/sis_driver.c
|
|
+++ b/src/sis_driver.c
|
|
@@ -2738,7 +2738,7 @@ SiSPrintModes(ScrnInfoPtr pScrn)
|
|
float hsync, refresh = 0.0;
|
|
char *desc, *desc2, *prefix, *uprefix, *output;
|
|
|
|
- xf86DrvMsg(pScrn->scrnIndex, pScrn->virtualFrom, "Virtual size is %dx%d "
|
|
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO, "Virtual size is %dx%d "
|
|
"(pitch %d)\n", pScrn->virtualX, pScrn->virtualY,
|
|
pScrn->displayWidth);
|
|
|