mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
a545090ce5
Fixes <https://bugs.gnu.org/32170>. * gnu/packages/patches/python-cairocffi-dlopen-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-cairocffi)[inputs]: Add glib, gtk+, pango. [native-inputs]: Add python-pytest. [arguments]: Enable tests. [arguments]<#:phases>[patch-paths]: New phase.
10 lines
383 B
Diff
10 lines
383 B
Diff
--- cairocffi-0.8.0/cairocffi/__init__.py.orig 2018-07-16 11:00:59.075664158 +0200
|
|
+++ cairocffi-0.8.0/cairocffi/__init__.py 2018-07-16 17:09:42.471958015 +0200
|
|
@@ -35,6 +35,7 @@
|
|
return lib
|
|
except OSError:
|
|
pass
|
|
+ return ffi.dlopen(name)
|
|
raise OSError("dlopen() failed to load a library: %s" % ' / '.join(names))
|
|
|
|
|