mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
e214a22007
* guix/build-system/scons.scm (scons-build): Add build-targets and install-targets parameters. * guix/build/scons-build-system.scm (build, install): Adjust accordingly. * doc/guix.texi (Build Systems): Document it. * gnu/packages/installers.scm: New file, (make-nsis): New procedure, (nsis-x86_64, nsis-i686): New variables. * gnu/packages/patches/nsis-env-passthru.patch: New file. * gnu/local.mk (dist_patch_DATA, GNU_SYSTEM_MODULES): Adjust accordingly.
12 lines
357 B
Diff
12 lines
357 B
Diff
--- nsis-3.04-src/SConstruct 2019-05-30 14:53:30.276775332 -0400
|
|
+++ nsis-3.04-src/SConstruct 2019-05-30 14:54:17.901232914 -0400
|
|
@@ -77,6 +77,9 @@
|
|
if not toolset and not path:
|
|
defenv = Environment(TARGET_ARCH = arch)
|
|
|
|
+import os;
|
|
+defenv['ENV'] = os.environ
|
|
+
|
|
Export('defenv')
|
|
|
|
######################################################################
|