mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-27 14:52:05 -05:00
29c94dd522
* gnu/packages/image.scm (freeimage)[source]: Add patches. * gnu/packages/patches/freeimage-CVE-2020-21428.patch, gnu/packages/patches/freeimage-CVE-2020-22524.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them. Change-Id: Iec114f2295cafbc8b55e81c0d8e4a361fd653152
17 lines
852 B
Diff
17 lines
852 B
Diff
https://sources.debian.org/data/main/f/freeimage/3.18.0%2Bds2-10/debian/patches/r1877-improved-DDS-plugin-against-malicious-images.patch
|
|
|
|
Origin: upstream, r1877
|
|
Index: Source/FreeImage/PluginDDS.cpp
|
|
===================================================================
|
|
diff --git a/Source/FreeImage/PluginDDS.cpp b/Source/FreeImage/PluginDDS.cpp
|
|
--- a/Source/FreeImage/PluginDDS.cpp (revision 1876)
|
|
+++ b/Source/FreeImage/PluginDDS.cpp (revision 1877)
|
|
@@ -617,7 +617,7 @@
|
|
// read the file
|
|
// -------------------------------------------------------------------------
|
|
|
|
- const int line = CalculateLine(width, bpp);
|
|
+ const int line = CalculateLine(width, FreeImage_GetBPP(dib));
|
|
const int filePitch = ((desc->dwFlags & DDSD_PITCH) == DDSD_PITCH) ? (int)desc->dwPitchOrLinearSize : line;
|
|
const long delta = (long)filePitch - (long)line;
|
|
|