mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
b7028a16e6
* gnu/packages/video.scm (x265)[source]: Update list of patches. [arguments]: Change configure flag to ensure PIC for all architectures. * gnu/packages/patches/x265-arm-asm-primitives.patch: Remove file. * gnu/packages/patches/x265-detect512-all-arches.patch: New file. * gnu/local.mk (dist_patch_DATA): Update patch registry.
37 lines
866 B
Diff
37 lines
866 B
Diff
https://sources.debian.org/data/main/x/x265/2.9-3/debian/patches/0003-detect512-is-needed-on-all-architectures.patch
|
|
|
|
From: Adam Sampson <unknown@bitbucket>
|
|
Date: Sun, 14 Oct 2018 14:04:18 +0200
|
|
Subject: detect512 is needed on all architectures
|
|
|
|
---
|
|
source/common/cpu.cpp | 9 +++++----
|
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
|
|
index 0681ff5..fa687da 100644
|
|
--- a/source/common/cpu.cpp
|
|
+++ b/source/common/cpu.cpp
|
|
@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
|
|
{ "", 0 },
|
|
};
|
|
|
|
+bool detect512()
|
|
+{
|
|
+ return(enable512);
|
|
+}
|
|
+
|
|
#if X265_ARCH_X86
|
|
|
|
extern "C" {
|
|
@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
|
|
#pragma warning(disable: 4309) // truncation of constant value
|
|
#endif
|
|
|
|
-bool detect512()
|
|
-{
|
|
- return(enable512);
|
|
-}
|
|
uint32_t cpu_detect(bool benableavx512 )
|
|
{
|
|
|