mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
44a33ee90d
* gnu/packages/patches/texlive-bin-poppler-0.86.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/tex.scm (texlive-bin)[source](patches): Add it.
17 lines
841 B
Diff
17 lines
841 B
Diff
Fix build with Poppler 0.86 and later.
|
|
|
|
Taken from Arch Linux, but adjusted to patch the versioned Poppler
|
|
files, as upstream applies it after copying them in place.
|
|
https://git.archlinux.org/svntogit/packages.git/tree/trunk/texlive-poppler-0.86.patch?h=packages/texlive-bin
|
|
|
|
--- a/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:11:35.102711802 +0000
|
|
+++ b/texk/web2c/pdftexdir/pdftoepdf-poppler0.76.0.cc 2020-03-03 21:13:13.057420111 +0000
|
|
@@ -757,7 +757,7 @@
|
|
if (page_name) {
|
|
// get page by name
|
|
GString name(page_name);
|
|
- LinkDest *link = pdf_doc->doc->findDest(&name);
|
|
+ LinkDest *link = pdf_doc->doc->findDest(&name).get();
|
|
if (link == 0 || !link->isOk())
|
|
pdftex_fail("PDF inclusion: invalid destination <%s>", page_name);
|
|
Ref ref = link->getPageRef();
|