mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
1328c4cca5
* gnu/packages/patches/glibc-2.35-CVE-2023-4911.patch: New file. * gnu/local.mk: Register it here. * gnu/packages/base.scm (glibc/fixed): New variable. (glibc): Use it as replacement.
160 lines
5.2 KiB
Diff
160 lines
5.2 KiB
Diff
From 1056e5b4c3f2d90ed2b4a55f96add28da2f4c8fa Mon Sep 17 00:00:00 2001
|
|
From: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
|
Date: Tue, 19 Sep 2023 18:39:32 -0400
|
|
Subject: [PATCH 1/1] tunables: Terminate if end of input is reached
|
|
(CVE-2023-4911)
|
|
|
|
The string parsing routine may end up writing beyond bounds of tunestr
|
|
if the input tunable string is malformed, of the form name=name=val.
|
|
This gets processed twice, first as name=name=val and next as name=val,
|
|
resulting in tunestr being name=name=val:name=val, thus overflowing
|
|
tunestr.
|
|
|
|
Terminate the parsing loop at the first instance itself so that tunestr
|
|
does not overflow.
|
|
|
|
This also fixes up tst-env-setuid-tunables to actually handle failures
|
|
correct and add new tests to validate the fix for this CVE.
|
|
|
|
Signed-off-by: Siddhesh Poyarekar <siddhesh@sourceware.org>
|
|
Reviewed-by: Carlos O'Donell <carlos@redhat.com>
|
|
---
|
|
Backported to 2.35 by Liliana Marie Prikler <liliana.prikler@gmail.com>
|
|
|
|
NEWS | 5 +++++
|
|
elf/dl-tunables.c | 17 +++++++++-------
|
|
elf/tst-env-setuid-tunables.c | 37 +++++++++++++++++++++++++++--------
|
|
3 files changed, 44 insertions(+), 15 deletions(-)
|
|
|
|
Index: glibc-2.35/NEWS
|
|
===================================================================
|
|
--- glibc-2.35.orig/NEWS
|
|
+++ glibc-2.35/NEWS
|
|
@@ -199,6 +199,11 @@ Security related changes:
|
|
corresponds to the / directory through an unprivileged mount
|
|
namespace. Reported by Qualys.
|
|
|
|
+ CVE-2023-4911: If a tunable of the form NAME=NAME=VAL is passed in the
|
|
+ environment of a setuid program and NAME is valid, it may result in a
|
|
+ buffer overflow, which could be exploited to achieve escalated
|
|
+ privileges. This flaw was introduced in glibc 2.34.
|
|
+
|
|
The following bugs are resolved with this release:
|
|
|
|
[12889] nptl: Race condition in pthread_kill
|
|
Index: glibc-2.35/elf/dl-tunables.c
|
|
===================================================================
|
|
--- glibc-2.35.orig/elf/dl-tunables.c
|
|
+++ glibc-2.35/elf/dl-tunables.c
|
|
@@ -187,11 +187,7 @@ parse_tunables (char *tunestr, char *val
|
|
/* If we reach the end of the string before getting a valid name-value
|
|
pair, bail out. */
|
|
if (p[len] == '\0')
|
|
- {
|
|
- if (__libc_enable_secure)
|
|
- tunestr[off] = '\0';
|
|
- return;
|
|
- }
|
|
+ break;
|
|
|
|
/* We did not find a valid name-value pair before encountering the
|
|
colon. */
|
|
@@ -251,9 +247,16 @@ parse_tunables (char *tunestr, char *val
|
|
}
|
|
}
|
|
|
|
- if (p[len] != '\0')
|
|
- p += len + 1;
|
|
+ /* We reached the end while processing the tunable string. */
|
|
+ if (p[len] == '\0')
|
|
+ break;
|
|
+
|
|
+ p += len + 1;
|
|
}
|
|
+
|
|
+ /* Terminate tunestr before we leave. */
|
|
+ if (__libc_enable_secure)
|
|
+ tunestr[off] = '\0';
|
|
}
|
|
#endif
|
|
|
|
Index: glibc-2.35/elf/tst-env-setuid-tunables.c
|
|
===================================================================
|
|
--- glibc-2.35.orig/elf/tst-env-setuid-tunables.c
|
|
+++ glibc-2.35/elf/tst-env-setuid-tunables.c
|
|
@@ -52,6 +52,8 @@ const char *teststrings[] =
|
|
"glibc.malloc.perturb=0x800:not_valid.malloc.check=2:glibc.malloc.mmap_threshold=4096",
|
|
"glibc.not_valid.check=2:glibc.malloc.mmap_threshold=4096",
|
|
"not_valid.malloc.check=2:glibc.malloc.mmap_threshold=4096",
|
|
+ "glibc.malloc.mmap_threshold=glibc.malloc.mmap_threshold=4096",
|
|
+ "glibc.malloc.check=2",
|
|
"glibc.malloc.garbage=2:glibc.maoc.mmap_threshold=4096:glibc.malloc.check=2",
|
|
"glibc.malloc.check=4:glibc.malloc.garbage=2:glibc.maoc.mmap_threshold=4096",
|
|
":glibc.malloc.garbage=2:glibc.malloc.check=1",
|
|
@@ -70,6 +72,8 @@ const char *resultstrings[] =
|
|
"glibc.malloc.perturb=0x800:glibc.malloc.mmap_threshold=4096",
|
|
"glibc.malloc.mmap_threshold=4096",
|
|
"glibc.malloc.mmap_threshold=4096",
|
|
+ "glibc.malloc.mmap_threshold=glibc.malloc.mmap_threshold=4096",
|
|
+ "",
|
|
"",
|
|
"",
|
|
"",
|
|
@@ -89,6 +93,8 @@ test_child (int off)
|
|
|
|
if (val != NULL)
|
|
printf ("[%d] Unexpected GLIBC_TUNABLES VALUE %s\n", off, val);
|
|
+ else
|
|
+ printf ("[%d] GLIBC_TUNABLES environment variable absent\n", off);
|
|
|
|
return 1;
|
|
#else
|
|
@@ -117,21 +123,26 @@ do_test (int argc, char **argv)
|
|
if (ret != 0)
|
|
exit (1);
|
|
|
|
- exit (EXIT_SUCCESS);
|
|
+ /* Special return code to make sure that the child executed all the way
|
|
+ through. */
|
|
+ exit (42);
|
|
}
|
|
else
|
|
{
|
|
- int ret = 0;
|
|
-
|
|
/* Spawn tests. */
|
|
for (int i = 0; i < array_length (teststrings); i++)
|
|
{
|
|
char buf[INT_BUFSIZE_BOUND (int)];
|
|
|
|
- printf ("Spawned test for %s (%d)\n", teststrings[i], i);
|
|
+ printf ("[%d] Spawned test for %s\n", i, teststrings[i]);
|
|
snprintf (buf, sizeof (buf), "%d\n", i);
|
|
+ fflush (stdout);
|
|
if (setenv ("GLIBC_TUNABLES", teststrings[i], 1) != 0)
|
|
- exit (1);
|
|
+ {
|
|
+ printf (" [%d] Failed to set GLIBC_TUNABLES: %m", i);
|
|
+ support_record_failure ();
|
|
+ continue;
|
|
+ }
|
|
|
|
int status = support_capture_subprogram_self_sgid (buf);
|
|
|
|
@@ -139,9 +150,14 @@ do_test (int argc, char **argv)
|
|
if (WEXITSTATUS (status) == EXIT_UNSUPPORTED)
|
|
return EXIT_UNSUPPORTED;
|
|
|
|
- ret |= status;
|
|
+ if (WEXITSTATUS (status) != 42)
|
|
+ {
|
|
+ printf (" [%d] child failed with status %d\n", i,
|
|
+ WEXITSTATUS (status));
|
|
+ support_record_failure ();
|
|
+ }
|
|
}
|
|
- return ret;
|
|
+ return 0;
|
|
}
|
|
}
|
|
|